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Programme d' interprétation de fichiers et de traduction dansla DTD Corpus

A. EXEMPLE DE TRAITEMENT

1. Comportement du programme : quelques pointsparticuliers

Signalons en quel ques mots des propriétés du programme de passage de HTML a Corpus :

* |e programme n’ achoppe pas sur une balise fermante sans balise ouvrante correspondante, ou vice
versa (bien sOr, y compris hors des cas normaux de balises implicites, prévus par |’ option
OMITTAG) ;

« il rétablit des balises manifestement manquantes, lors de transitions trop abruptes (par exemple, si
la page commence par une balise u1 ou p, oubliant les éléments délimitant le document comme
HTML OU BODY) ;

e un éément introduisant une image peut avoir, dans un attribut appelé art, une valeur textuelle
destinée aremplacer I' affichage de I'image si celui-ci ne peut étre effectué : le programme recueille
ces indications textuelles, au fil de la page; elles peuvent ainsi étre prises en compte pour une
caractérisation de la page via son texte ;

 une page vide, munie uniquement d’un titre, est interprétée et traduite comme telle. Ceci est un cas
limite, car letitre (au sensHTML) n'est pas ce qui est affiché en haut d' une page, il est au contraire
peu visible. 1l appardit par exemple sur I’encadrement de la fenétre du navigateur, ou comme
désignation de la page quand on en enregistre | adresse par un signet (bookmark).

Ces cas ont été prévus dans I’ implémentation, et le comportement du programme a été testé et
validé notamment sur eux.

2. Unepagedu sitedu W3C

a) Commentaires

Cette page est conforme a la DTD HTML 3.2 (validation par un parseur). Le programme
serait également capable de traiter des pages avec des irrégularités par rapport a cette DTD, —’ est
méme sa motivation initiale.

Il est intéressant de voir comment le traitement se comporte sur cette page car elle présente
une certaine variété de dispositions classiques de texte : intitul és, parties rédigées, listes, etc.

b) La page, tellequ’elle est visualisée
cf. copies d’ écran ci-apres.
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ctscape - [HyperT ext Markup Language [HT|

e E View Go Bookmarks Options Directory Window Help

sl e | @ (% |2 |5 @) @
Back | Forverd [ Home Reload [ Ireaes | Gpen Frint Find Ztip

File Edit View Go Bookmarks Options Directory Yindow Help
=T | @
Bask | Forerd | Heme Relosd | Ircges | Open | Pnt Find Gtz

|g] Location: [Fie:/7/00home /PINCEMINcoreus w3t pagehirl bim
What'sNew? | \hal's Cool? | Destinations | Net Search | People | Software |

i HyperText Markup Language (HTML)

HTML is a markup language for hypertext which is used in WIWW clients. This is an overview of all
HTML related materiale here at W3C and around the web.

The current W3C Eecommendation for HTIML is HTML 3.2
The latest specification 15 the working draft for HIML 4.0, This is work m progress and 15 expected

to become a proposed recommendation after a period of public review. Here is a link to the press
release announcing the first public draft.

IT& W3C Activity Statement on HTML

The W3C statement of direction concerning the evolution of HIML. Goals, on going work, relation
to other W3C activities.

(Questions, comments, and suggestions about HTML

There are several kinds of discussion forums te cheose from. Be sure to check the archives and

FAQs first

Cougar

TW3C's next version of HTML is being developed by the HIML Wetking Group. This has now been
formally announced as HTIML 4.0

HTML, Hypertext Links and Referer URLs

is8| [ Quick Link: Diag this location fo Boskmarks efc. Double-Click fo copptaclpboard, | =7

Edit Yiew Go Bookmarks Options

] Location: [fie: /Tl hameFINCEMIN Fcormus vz pagehiml Fim
WhatsNew? | Whats Cool? | Destinations | MetSeaich | People | Saltware |

s -

In a vacuum, semantically nevtral technology attracts meamng, Ifneutral technology is useful,
commerce -- abhorring a vacuum -- uses technology in often-unforeseen ways to build new markets
Ower the past year we have seen attempts to create meanng for HTML references where none
exsted before. Links have been argued to mean revenue streams, approval, a source of liability,
endorsement, and ownership

The Web depends on hypertext links between resources. Links can act as references, of to embed
material, both of which are concepts that have been around for a long long time. Whats new with the
Web is the ability to follow links quickly.

When a user clicks on a link, the URL of the page containing the link is passed to the server along
with the recquested URL. This gives Web sites the opportunity to customize the response according
to the page the user clicked on.

If someone jumps into a Web site without entering wia the home page, a content provider may
choose to tumn them away or to redirect them to the home page. A smarter Web site could use partial
string matches on the Referer and Requested URLs to custormize the page it returns.

One reason for deing this is to ensure visitors see the banner ads and promotions, a site is using to
create revenue; another is to avoid broken links when people (or indexing engines) bookmark
transitory Web pages.

The Referer URL can also be used to determine how to honor requests for images or applets. For
instance, you might decide to only provide images to sites which have signed a license agreement with
you.

News (more...)
® 3 Anril 97 Clonaar related drafts are made nrhlic =
ol | =7

etscape - [HypesText Markup Language [HT|
e Edit View Go Bookmarks Options

ing and Background Materials]
ectory Window Help

Sl e @ [ | &S| @] @
Back | Forverd [ Home Reload [ =az= | Open Print Find S

w o || &|w || & @a| ®
Back Forerd | Home Reload | Imsges Open Print Find =T

(] Location [fie /770 home/PINCEMIN/corpus wicpagehtmlbim
What's New? | Whals Cool? | Destinations | Net Search | Peaple | Software |

] Loation [l /2/C)/home/PINCEMIN corpus/wac page il im
What'sNew? | Whats Coo? | Destinations | NetSeaich | Peaple | Software |

* 14 Jan 97: HIML 3.2 becomes a W3C Recom dation

* 5Nov 96 HTML 3.2 becomes a W3C Propesed Recor !

* 30 Septemher 96: Meeting of an HTIML -Math Tnterest Group

* 10 July 96: experimental draft of HTML DTD including style sheets, scripting, the object tag,
internationalization and some extensions to forms

* 7 May 96: Introducing HTWMT, 3.2 (Press Release)

= 25 April 96 W3C Workshop on High Quality Printing from the Web

Learning and Using HTML

* Information Provider Materials including A style guide for online hypertext, the HTTP
protocol, the serwer puide | clickable images, etc

* Web Tools including HTML editors, filters, and converters

* HTWI Reference Manual by Michael J. Hannah, Sandia National Laboratories

* Frequently &sked Questions about web authorng, by Thomas Boutell

* Web Developer's section of the WWW Virtual Library, 1 by Alan Richmond.

* HIML info in the Tahoo collection

* Hyperllews page on HTIML mai

d by Daniel LaLiberte at IC34A.

Specs and Drafts
Publshed specs: W3C working drafts, IETF drafts and RFCs, etc. A few works n progress
Testing and Certification
The W3C HIML 3.2 Recommendation defines conformance of HIML documents (web
pages) and certain aspects of HIWL user agents (web browsers). HIML 3.2 adds widely
deployed features such as tables, applets and text flow around images, superscripts and
subscripts while providing backwards compatibility with the existing HTML 2.0 Standard

In order to promote reliability and fidelity of communications on the web, W3C is coordinating
testing efforts

Related Resources =l
sl | I B? 7

Related Resources
If what you're looking for ien't here, it may be elsewhere here at W3C

SGML
The architecture behind HTML. Introductory materials, W3C Activity.

Style Sheets
Cascading Stylesheets and related proposals for adding more presentational control for
HIML

Document Obiect Model
"Dynamic HTML" is a term used by some wendors to describe the combination of HTML,
style sheets and scripts that allows documents to be animated. The W3C Document Object
Model Working Group is working hard to make sure interoperable and scripting-language
neutral solutions are agreed upon,

Internationalization
Support for western european writing systems is widespread. Support for eastern european,
CIE, and other writing systems, as well as mixed-languge documents, is in the works. Issues
include character sets, encodings, bi-directional rendering, fonts, currency and date formats,

Access for People with Disabilities
One major feature of HTML is that it can be rendered in braille, by speech synthesys system,
ete

Iathematice
Work on representing mathematics m HTML.

Dave Raggett, Arnaud Le Hors, contact persons for the W3C HTML Activity
Dan Connolly, chair of the W3C HTML Working Growp (tmembers only)
$Date: 199710002 13:50:05 §

Copyright @ 1997 W3C (MIT, INEL4, Keio), All Rights Reserved. W3C liability, trademark, document use and ﬂ
Tl | [ =

Figure 1 : La page choisie comme exemple, telle qu’elle s affiche dans un navigateur Web.
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c) Lecodage HTML delapage

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2//EN" >
<HTML>
<HEAD>
<TITLE>HyperText Markup Language (HTML): Working and Background
Materials</TITLE>
</HEAD>

<BODY BGCOLOR="#FFFFFF" TEXT="#000000">

<P>
<A HREF="../"><IMG BORDER="0" ALT="W3C" SRC="../Icons/WWW/w3c_ home"></A>
<H1>

<IMG SRC="../Icons/WWW/html 48x48"> HyperText Markup Language (HTML)
</H1>

<P>HTML is a markup language for hypertext which is used in WWW
clients. This is an overview of all HTML related materials here at W3C and
around the web.

<p>The current W3C Recommendation for HTML is <a href="Wilbur/">HTML
3.2</A>.

<p>The latest specification is the working draft for

<a href="/TR/WD-html40/">HTML 4.0</a>. This is work in progress and
is expected to become a proposed recommendation after a period of
public review. Here is a link to the <a href="/Press/HTML4">press
release</a> announcing the first public draft.

<H3><A HREF="Activity"><IMG BORDER="0" SRC:"../IconS/WWW/aCtiVityi48X48"
WIDTH="48" HEIGHT="48" align=middle> W3C Activity Statement on
HTML</A></H3>

<P>The W3C statement of direction concerning the evolution of HTML. Goals,

on going work, relation to other W3C activities.

<H3>Questions, comments, and suggestions about HTML</H3>

<P>There are several kinds of <A HREF="Forums"
NAME="discussion">discussion

forums</A> to choose from. Be sure to check the archives and <A

HREF="http://www.boutell.com/fag/#authoring">FAQ</A>s first.

<H3><a href="Cougar/">Cougar</a></H3>
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<p>W3C’s next version of HTML is being developed by the HTML Working
Group.

This has now been formally announced as <a href="/TR/WD-html40/">HTML
4.0</a>.

<hr>
<h3><a name="1links">HTML, Hypertext Links and Referer URLs</a></h3>

<p>In a vacuum, semantically neutral technology attracts meaning.
If neutral technology is useful, commerce -- abhorring a vacuum --
uses technology in often-unforeseen ways to build new markets.
Over the past year we have seen attempts to create meaning for
HTML references where none existed before. Links have been argued
to mean revenue streams, approval, a source of liability,
endorsement, and ownership.

<p>The Web depends on hypertext links between resources. Links can
act as references, or to embed material, both of which are concepts
that have been around for a long long time. Whats new with the Web
is the ability to follow links quickly.

<p>When a user clicks on a link, the URL of the page containing
the link is passed to the server along with the requested URL.
This gives Web sites the opportunity to customize the response
according to the page the user clicked on.

<p>If someone jumps into a Web site without entering via

the home page, a content provider may choose to turn them
away or to redirect them to the home page. A smarter Web

site could use partial string matches on the Referer and

Requested URLs to customize the page it returns.

<p>One reason for doing this is to ensure visitors see the
banner ads and promotions, a site is using to create revenue;
another is to avoid broken links when people (or indexing
engines) bookmark transitory Web pages.

<p>The Referer URL can also be used to determine how to
honor requests for images or applets. For instance,

you might decide to only provide images to sites which
have signed a license agreement with you.

<hr>

<H3>News (<A HREF="../News/">more...</A>)</H3>

<UL>
<li><strong>3 April 97</strongs>: <a href="Cougar/">Cougar</a> related
drafts are made public.

<li><strong>14 Jan 97</strong>: <a href="Wilbur/">HTML 3.2</A> becomes a
<a href="../Consortium/Process/Recommendation">W3C Recommendation</A>.

<lis<strong>5 Nov 96</strong>: <a href="Wilbur/">HTML 3.2</A> becomes a

Programme d’interprétation de fichiers et de traduction dansla DTD Corpus
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<a href="../Consortium/Process/Recommendation">W3C Proposed
Recommendation</A>.

<li><strong>30 September 96</strong>: <a
href="http://www.ams.org/html-math/meeting-960930-notes.html">Meeting of
an HTML-Math Interest Group</a>

<li><strong>10 July 96</strong>: experimental draft of <a
href="Cougar/HTML.dtd">HTML DTD</A> including style sheets, scripting,
the object tag, internationalization and some extensions to forms.

<li><strong>7 May 96</STRONG>: <A href="Wilbur/">Introducing HTML
3.2</A>
(<A href="Wilbur/pr7may96">Press Release</A>)

<li><strong>25 April 96</STRONG>: <A

HREF="../Printing/Workshop 960425">W3C Workshop on High Quality Printing
from the Web</A>
</UL>

<H3>Learning and Using HTML</H3>

<UL>
<LI><A href="../Provider/">Information Provider Materials</A> including
<A HREF="../Provider/Style/"> A style guide</A> for online hypertext, <A
HREF="../Protocols/"> the HTTP protocol</A>, <A HREF="../Daemon/User/">

the server guide</A> ,&nbsp;clickable images, etc.

<LI><A href="../Tools/">Web Tools</A> including HTML editors, filters,
and converters

<LI><A HREF="http://www.sandia.gov/sci compute/html ref.html">HTML
Reference Manual</A> by Michael J. Hannah, Sandia National Laboratories
<!-- &lt;mjhanna@sandia.gov&gt; -->

<LI><A HREF="http://www.boutell.com/faqg/#authoring">Frequently Asked
Questions</A> about web authoring, by Thomas Boutell

<LI><A href="http://WWW.Stars.com/V1lib/">Web Developer’s section</A> of
the <A HREF="../../DataSources/"> WWW Virtual Library</A>, maintained by
Alan Richmond.

<LI><A href="http://www.yahoo.com/Computers/World Wide Web/HTML/">HTML
info </A>in the Yahoo collection

<LI><A
href="http://union.ncsa.uiuc.edu/HyperNews/get/www/html.html">HyperNews
page on HTML</A> maintained by Daniel LaLiberte at NCSA.

</UL>

<DL>

ANNEXE V.3

<DT>
<A NAME="specs" HREF="Bibliography">Specs and Drafts</A>
<DD>
Published specs: W3C working drafts, IETF drafts and RFCs, etc. A few
<A HREF="Bibliography#in-progress">works in progress</A>
<DT>
<A href="html-test/">Testing and Certification</A>
<DD>
The W3C <A href="../TR/REC-html32.html">HTML 3.2 Recommendation</a>
defines conformance of HTML documents (web pages) and certain aspects
of HTML user agents (web browsers). HTML 3.2 adds widely deployed
features such as tables, applets and text flow around images,
superscripts
and subscripts while providing backwards compatibility with the
existing
<A href="html-spec/">HTML 2.0 Standard</a>.

<P>In order to promote reliability
and fidelity of communications on the web, W3C is coordinating testing
efforts.</P>

</DL>

<H3><A name="related">Related Resources</A></H3>
<P>
If what you’re looking for isn’t here, it may be elsewhere here at W3C:
<DL>

<DT>
<A href="SGML/">SGML</A>

<DD>
The architecture behind HTML. Introductory materials,
<A HREF="SGML/Activity">W3C Activity</A>.

<DT>
<A HREF="../Style/">Style Sheets</A>

<DD>
Cascading Stylesheets and related proposals for adding more
presentational control for HTML.

<DT>
<A HREF="DOM/">Document Object Model</A>

<DD>"Dynamic HTML" is a term used by some vendors to describe the

combination of HTML, style sheets and scripts that allows documents to be
animated.
The W3C Document Object Model Working Group is working hard to make sure
interoperable and scripting-language neutral solutions are agreed upon.

<DT>
<A href="../International/">Internationalization</A>

<DD>
Support for western european writing systems is widespread. Support

for

eastern european, CJK, and other writing systems, as well as
mixed-languge documents, is in the works. Issues include character
sets, encodings, bi-directional rendering, fonts, currency and date
formats,

<DT>



<A HREF="../Disabilities/">Access for People with Disabilities</A>
<DD>
One major feature of HTML is that it can be rendered in braille, by
speech synthesys system, etc.
<DT>
<A HREF="Math/">Mathematics</A>
<DD>
Work on representing mathematics in HTML.

</DL>
<P>

<HR>
<ADDRESS >
<p><A href="../People/Raggett/">Dave Raggett</A>, <a
href="../People/Arnaud/">Arnaud Le Hors</a>, contact persons for the <a
href="Activity">W3C HTML Activity</a><br> <a href="../People/Connolly">Dan
Connolly</a>, chair of the <A href="Group/">W3C HTML Working Group</a> (<a
href="../Help/AccessForm">members only</a>)<br>
$Date: 1997/10/02 13:50:05 3
</ADDRESS>
<p>
<small><a href="../Consortium/Legal/ipr-

notice.html#Copyright">Copyright</a>

&nbsp; &copy; &nbsp;

1997 <a href="http://www.w3.org">W3C</a> (<a
href="http://www.lcs.mit.edu">MIT</a>,

<a href="http://www.inria.fr/">INRIA</a>, <a
href="http://www.keio.ac.jp/">Keio</a> ),

All Rights Reserved.

W3C <a href="../Consortium/Legal/ipr-notice.html#Legal
Disclaimer">liability,</a>

<a href="../Consortium/Legal/ipr-notice.html#W3C Trademarks">trademark</a>,
<a href="../Consortium/Legal/copyright-documents.html">document use </as>and
<a href="../Consortium/Legal/copyright-software.html">software licensing
</a>rules apply.

Your interactions with this site are in accordance with our

<a href="../Consortium/Legal/privacy-statement.html#Public">public</a> and
<a href="../Consortium/Legal/privacy-statement.html#Members">Member</a>
privacy statements.</smalls

</p>

</BODY>

</HTML>
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d) Traduction obtenue dansla DTD Corpus

(Pour une meilleure lisibilité, a été misen gras ce qui a é&té repéré par le programme
comme ayant une fonction d’intitulé, et qui a été transcrit par des é éments HEAD et TIT
dela DTD Corpus)

<CORPUS><DOC><TEXT><TIT>HyperText Markup Language (HTML): Working and
Background Materials</TIT>

<NLS> W3C </NLS>

<HEAD> HyperText Markup Language (HTML) </HEAD>

<NLS>HTML is a markup language for hypertext which is used in WWW clients.
This is an overview of all HTML related materials here at W3C and around
the web. </NLS>

<NLS>The current W3C Recommendation for HTML is HTML 3.2. </NLS>

<NLS>The latest specification is the working draft for HTML 4.0. This is
work in progress and is expected to become a proposed recommendation after
a period of public review. Here is a link to the press release announcing
the first public draft. </NLS>

<HEAD> W3C Activity Statement on HTML</HEAD>

<NLS>The W3C statement of direction concerning the evolution of HTML.
Goals, on going work, relation to other W3C activities. </NLS>
<HEAD>Questions, comments, and suggestions about HTML</HEAD>

<NLS>There are several kinds of discussion forums to choose from. Be sure
to check the archives and FAQs first. </NLS»>

<HEAD>Cougar</HEAD>

<NLS>W3C’s next version of HTML is being developed by the HTML Working
Group. This has now been formally announced as HTML 4.0. </NLS>

<HEAD>HTML, Hypertext Links and Referer URLs</HEAD>

<NLS>In a vacuum, semantically neutral technology attracts meaning. If
neutral technology is useful, commerce -- abhorring a vacuum -- uses
technology in often-unforeseen ways to build new markets. Over the past
year we have seen attempts to create meaning for HTML references where none
existed before. Links have been argued to mean revenue streams, approval, a
source of liability, endorsement, and ownership. </NLS>

<NLS>The Web depends on hypertext links between resources. Links can act as
references, or to embed material, both of which are concepts that have been
around for a long long time. Whats new with the Web is the ability to
follow links quickly. </NLS>

<NLS>When a user clicks on a link, the URL of the page containing the link
is passed to the server along with the requested URL. This gives Web sites
the opportunity to customize the response according to the page the user
clicked on. </NLS>

<NLS>If someone jumps into a Web site without entering via the home page, a
content provider may choose to turn them away or to redirect them to the
home page. A smarter Web site could use partial string matches on the
Referer and Requested URLs to customize the page it returns. </NLS>
<NLS>One reason for doing this is to ensure visitors see the banner ads and
promotions, a site is using to create revenue; another is to avoid broken
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links when people (or indexing engines) bookmark transitory Web pages.
</NLS>

<NLS>The Referer URL can also be used to determine how to honor requests
for images or applets. For instance, you might decide to only provide
images to sites which have signed a license agreement with you. </NLS>
<HEAD>News (more...)</HEAD>

<BLCK><ITEM><NLS>3 April 97: Cougar related drafts are made public. </NLS>
</ITEM>

<ITEM><NLS>14 Jan 97: HTML 3.2 becomes a W3C Recommendation. </NLS>
</ITEM>

<ITEM><NLS>5 Nov 96: HTML 3.2 becomes a W3C Proposed Recommendation. </NLS>
</ITEM>

<ITEM><NLS>30 September 96: Meeting of an HTML-Math Interest Group</NLS>
</ITEM>

<ITEM><NLS>10 July 96: experimental draft of HTML DTD including style
sheets, scripting, the object tag, internationalization and some extensions
to forms. </NLS>

</ITEM>

<ITEM><NLS>7 May 96: Introducing HTML 3.2 (Press Release) </NLS>

</ITEM>

<ITEM><NLS>25 April 96: W3C Workshop on High Quality Printing from the
Web</NLS>

</ITEM>

</BLCK>

<HEAD>Learning and Using HTML</HEAD>

<BLCK><ITEM><NLS>Information Provider Materials including A style guide
for online hypertext, the HTTP protocol, the server guide , clickable
images, etc. </NLS»>

</ITEM>

<ITEM><NLS>Web Tools including HTML editors, filters, and converters </NLS>
</ITEM>

<ITEM><NLS>HTML Reference Manual by Michael J. Hannah, Sandia National
Laboratories </NLS>

</ITEM>

<ITEM><NLS>Frequently Asked Questions about web authoring, by Thomas
Boutell </NLS>

</ITEM>

<ITEM><NLS>Web Developer’s section of the
by Alan Richmond. </NLS>

</ITEM>

<ITEM><NLS>HTML info in the Yahoo collection </NLS>

</ITEM>

<ITEM><NLS>HyperNews page on HTML maintained by Daniel LalLiberte at NCSA.
</NLS>

</ITEM>

</BLCK>

<BLCK><ITEM><HEAD>Specs and Drafts</HEAD>

<NLS> Published specs: W3C working drafts, IETF drafts and RFCs, etc. A few
works in progress</NLS>

</ITEM>

<ITEM><HEAD>Testing and Certification</HEAD>

WWW Virtual Library, maintained
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<NLS> The W3C HTML 3.2 Recommendation defines conformance of HTML documents
(web pages) and certain aspects of HTML user agents (web browsers). HTML
3.2 adds widely deployed features such as tables, applets and text flow
around images, superscripts and subscripts while providing backwards
compatibility with the existing HTML 2.0 Standard. </NLS>

<NLS>In order to promote reliability and fidelity of communications on the
web, W3C is coordinating testing efforts.</NLS>

</ITEM>

</BLCK>

<HEAD>Related Resources</HEAD>

<NLS> If what you’re looking for isn’t here, it may be elsewhere here at
W3C: </NLS>

<BLCK><ITEM><HEAD>SGML</HEAD>

<NLS> The architecture behind HTML. Introductory materials, W3C Activity.
</NLS>

</ITEM>

<ITEM><HEAD>Style Sheets</HEAD>

<NLS> Cascading Stylesheets and related proposals for adding more
presentational control for HTML. </NLS>

</ITEM>

<ITEM><HEAD>Document Object Model</HEAD>

<NLS>"Dynamic HTML" is a term used by some vendors to describe the
combination of HTML, style sheets and scripts that allows documents to be
animated. The W3C Document Object Model Working Group is working hard to
make sure interoperable and scripting-language neutral solutions are agreed
upon. </NLS>

</ITEM>

<ITEM><HEAD>Internationalization</HEAD>

<NLS> Support for western european writing systems is widespread. Support
for eastern european, CJK, and other writing systems, as well as mixed-
languge documents, is in the works. Issues include character sets,
encodings, bi-directional rendering, fonts, currency and date formats,
</NLS>

</ITEM>

<ITEM><HEAD>Access for People with Disabilities</HEAD>

<NLS> One major feature of HTML is that it can be rendered in braille, by
speech synthesys system, etc. </NLS>

</ITEM>

<ITEM><HEAD>Mathematics</HEAD>

<NLS> Work on representing mathematics in HTML. </NLS>

</ITEM>

</BLCK>

<NLS>Dave Raggett, Arnaud Le Hors, contact persons for the W3C HTML
Activity Dan Connolly, chair of the W3C HTML Working Group (members only)
$Date: 1997/10/02 13:50:05 $ </NLS>

<NLS>Copyright © 1997 W3C (MIT, INRIA, Keio ), All Rights Reserved. W3C
liability, trademark, document use and software licensing rules apply. Your
interactions with this site are in accordance with our public and Member
privacy statements.</NLS>

</TEXT>

</DOC>

</CORPUS>
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B. ARCHITECTURE DU PROGRAMME ET DESCRIPTIF DES MODULES

Le développement a été fait en Ada, en raison de la puissance et de la solidité de ce langage,
et de la disponibilité d'un compilateur fiable, performant, développé et entretenu par les meilleurs
spécialistes (le compilateur GNAT). Ada est puissant, car il permet de réaliser de facon élégante tout
ce qui a jamais été congu en termes de programmation : sémantique maitrisée par un typage fort,
réutilisabilité (génériques, héritages, surcharges,...), modularité (dépendance, visibilités...), fiabilité
(traitement et remontée d’exceptions, initialisation et finalisation systématiques qui peuvent étre
utilisées pour les pointeurs), parallélisme, temps rédl,... Tous les éléments pour une programmation
objet sont & Ada est un langage de haut niveau, d’une grande lisibilité (facilitant |’ entretien et
I’ évolution des programmes) ; il est clair et précis (pas d' implicite confus). Normé, il est parfaitement
portable, et n’est pas dépendant d’une version de compilateur ou d'un choix de plate-forme. Pour en
savoir plus sur Ada, on peut lire I’ ouvrage trés complet de Norman H. COHEN (Cohen 1996), suivre
I’excellente formation dispensée par Jean-Pierre  ROSEN  (société Adaog, Vanves,
http://perso.wanadoo. fr/adalog), ou/et consulter le Manuel de référence d’ Ada95, disponible
sous forme hypertexte sur le site général Ada (http://www.adahome.com/).

Les suffixes .ads désignent des fichiers contenant des spécifications, les .adb explicitent la
mise en cauvre des traitements (b comme body, i.e. corps du programme).

1. Programmesdetraitement

a) Detexte simple vers Corpus

Lefichier asc2dcd.adb contient le programme qu'il faut lancer pour réaliser la transcription
d'un fichier ASCII simple en un fichier selonlaDTD Corpus.

b) Detexte ASCII misen forme vers Corpus

Lefichier csr2dcd.adb contient le programme qu'il faut lancer pour réaliser la transcription
d'un fichier ASCII mis en page (notamment les césures de lignes sont codées par des retours chariot)
en un fichier slon 1aDTD Corpus.

c) DeHTML vers Corpus

Le fichier ntm2dcd.adb contient le programme qu’il faut lancer pour réaliser la transcription
d'un fichier ASCII HTML «mou » (c'est-a-dire appliquant de fagcon approximative les DTD HTML
2.00u 3.2) enunfichier selon laDTD Corpus.

Le principe général utilisé pour contourner les blocages liés a une syntaxe rigide (conformité
stricte a la grammaire que représente la DTD) est 1a répartition des balises en niveaux : typiguement,
il y ades balises dont la portée est de I’ ordre du document (mettons sopy en HTML), d’ autres dont la
portée est de I'ordre d'un découpage en paragraphes ou en parties, d’autres intervenant sur un ou
quelques mots. Cette approche est expliquée au|chapitre V, 8C.3,

2. Leschainesde caracteres

a) Définition générique des chaines de caracteres pour DECID

Les spécifications decid_strings_g.ads fixent précisément les opérations dont on souhaite
doter (en puissance) tous les objets s apparentant & des chaines de caractéres (ce seront des ‘ chaines
de caracteres DECID’). Le fichier decid strings g.adb décrit une maniere de les effectuer : le
module est opérationnel.

Ce module est un générique (ce que nous signalons par le suffixe g, mnémonique), C est-&
dire qu'il ne définit aucun objet en lui-méme, mais donne un patron, un moule, pour créer
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instantanément et de facon unifiée les objets dont on a besoin. En I’ occurrence, les trois modules
suivants sont des instanciations de ce générique.

b) Ligne

Les lignes d'un fichier sont des chaines de caracteres dont la longueur est de I’ordre d'un
paragraphe. Le module 1ines.ads les définit donc comme des ‘chaines de caractéres DECID’ de
grande taille. Les lignes bénéficient de fait de toutes les possibilités de manipulations explicitées dans
le générique.

c) Chemin (nom complet d'un fichier)

Le module paths.ads correspond aux noms de fichiers, généralement donnés avec leur
chemin, a savoir la succession de répertoires emboités qui y conduit. Ce sont des chaines de caractéeres
DECID de longueur moyenne.

d) ldentifieur générique (en SGML)

Les generic identifiers de lanorme SGML (abrégés Gl) sont par exemple les noms des entités
SGML, ou les noms des balises. |ls s apparentent a des chaines de caractéres DECID courtes, sauf
gu'ils ne sont pas sensibles aux distinctions de casse (majuscules / minuscules) ; ils ne sont par
ailleurs susceptibles que de peu de manipulations et transformations. Le module sgm1_gis.ads (rendu
opératoire par sgml_gis.adb) détermine tout cela

3. Lessegments

Un segment est une unité, un éément, d'un fichier. L'idée est que cela doive permettre de
«lire intelligemment » les fichiers, sans les découper n'importe comment, a I’ aveuglette, sur des
critéres arbitraires comme par exemple la longueur d’ une chaine de caracteres ou les retours-chariots
(non significatifs en SGML).

a) Eléments généraux de définition
Opérations de nettoyage des fichiers (effacement ou remplacement de caractéres de contrdle).

b) Lessegmentsdanslesfichierstexte (.txt)
Base de définition des segments

Segment detypedata : le contenu d’un alinéa

Segment correspondant au contenu d' un paragraphe (ce peut étre le regroupement de plusieurs
lignes si lefichier a été mis en page avec des retours chariot).

Segment detype méta : séparation structurante
Séparation entre 2 paragraphes : saut de ligne(s), retrait...

Par cour s des segments d’un fichier texte simple
Opérations sur fichier ASCII simple (itérateur sur les segments).

Par cour s des segments d’un fichier texte misen forme
Opérations sur fichier ASCIl mis en page (itérateur sur les segments).
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Cc) Lessegmentsdanslesfichiers SGML
Base de définition des segments

Lessegmentsdetypedata: contenu textuel
C’ est grosso modo le #pcpaTa de lanorme SGML.

L es segments detype méta : les balises

Il s'agit des balises (par exemple <p> 0ou </p>) ; ce module est générique (et par conséquent
tous ses descendants aussi) car chague DTD a sa famille de balises (cf. le type énumératif
Tag_Category).

Balises ouvrantes

Balise ouvrante (par exemple <p), dite « start tag» dans la norme SGML. L’abréviation
« stag » est directement inspirée de la norme, qui note « stago » et « stagc » les délimiteurs de la balise
(start tag open, start tag close).

Balises fermantes
Balise fermante (par exemple </p> 0uU </>), dite « end tag » dans la norme SGML.

Segments de typeindéfini (data ou méta)

Segment polymorphe, lorsgu’il faut considérer indifféremment les segments «data»
(textuels) et « méta» (balises) d’un fichier.

L e contexte (emboitement des @ éments ouverts)
Définit et gere la pile des balises ouvertes, au fur et a mesure du parcours d’ un fichier.

Lestraitements contextuels

Le module segments-sgml-context g.process_g permet de définir des traitements associés
aux opérations d’ ouverture et de fermeture de balises.

d) Uneinstance de segments SGML : lessegmentsHTML

Définition du jeu de balises et de son compor tement

Cest dans le module segments-sgml-html que Sont regroupées toutes les informations
propresalaDTD HTML.

Modules qui en découlent
En dérive ensuite tout ce qui atrait aux balises, pour le casde HTML :

Balises

Balises ouvrantes
Balises fermantes
Balisesindéfinies

Contexte structurel
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e) Uneautreinstance de segments SGML : les segments Corpus

Définition du jeu de balises et de son compor tement

C'est dans le module segments-sgml-decid que sont regroupées toutes les informations
propresalaDTD Corpus.

Modules qui en découlent
De méme que pour HTML, tout ce qui est lié aux balises est actualisé pour cette autre DTD :

Balises
Le nom de ce module se termine en meta_pkg au lieu de meta, car il y a une balise nommée
meta danslejeu de balisesdelaDTD Corpus.

Balises ouvrantes
Balises fermantes
Balisesindéfinies
Contexte structurel

f) Schéma récapitulatif de |’ organisation de la famille « segments »

segments
|
[ |
txt sgml

etag_g mixed_g contexts_g

L égende

-------- > utilise
(with)

—» prend en
parametre

——P instancie

data objet final,
prét pour
utilisation

I I I
stag etag mixed contexts

[
meta
“html

4. Utilitaires

Ne sont pas présentés ici certains modules trés généraux et utilisés dans tous nos programmes,
comme:
 celui qui gére I’ouverture et la fermeture de fichiers passés en paramétres (il s agit pour nous d un
module que nous avons appelé files) ;
e celui qui soccupe des messages d erreur, de signaement ou dinformation diverses sur le
déroulement du traitement (notre module 10gs) ;
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e celui qui concerne les parametres d'installation du programme (localisation des fichiers de
données, de I’ espace de travail, des fichiers générés, valeurs par défaut de paramétres, etc.) (module
parameters).

a) Tailles: la gestion desordres de grandeur

Le module sizes effectue . Nous n’en donnons que les spécifications (. ads), le corps (. adb)
étant facile a (re)constituer et ne présentant pas de particularités significatives.

b) Lecturedefichierstabulés

Nous utilisons le module read files, congu et implémenté par Pascal OBRY. Nous n'en
donnons ici que les spécifications (.ads), qui sont ce que nos modules « voient », ce a quoi ils ont
acces.

c) Un générique pour construire et manipuler des objets polymorphes

Les principes de base de ce générique nous ont éé donnés par Pascal OBRY. Il sagit de
disposer d’'un modele (un générique, polymorphic_objects g) a partir duquel dériver simplement
des objets subsumant plusieurs types, ainsi qu’ une série d’ opérati ons associ €es.

5. Donnéesauxiliaires

a) Entités SGML

Les entités SGML servent notamment & coder tous les caractéres diacritiques et caracteres
spéciaux. Nous donnons un court extrait de notre table d’ association pour montrer comment elle se
présente.
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C. CODE SOURCE
1. Programmesdetraitement

a) Detexte simple vers Corpus

with Ada.Text IO;

with Files;

with Segments.Sgml.Data;

with Segments.Sgml.Decid;

with Segments.Sgml.Decid.Etag;
with Segments.Sgml.Decid.Stag;
with Segments.Txt.Data;

with Segments.Txt.Plain Ascii;

procedure Asc2dcd is
use Segments;
Ascii_File, Decid File : Ada.Text_ IO.File Type ;

procedure Translate (Object : in Segments.Txt.Data.Segment) is
begin

Sgml.Decid.Stag.Write (Tag => Sgml.Decid.Nls, File => Decid File);

Sgml.Data.Write (Object =>

Sgml.Data.Create (Content =>
Txt.Data.Get_Content (Object => Object)),
File => Decid File);

Sgml.Decid.Etag.Write (Tag => Sgml.Decid.Nls, File => Decid File);

end Translate;

procedure Translate Each_ Segment is
new Txt.Plain Ascii.For Each Segment G (Action => Translate);

begin

-- Files.Interactive Open (Which => "ASCII",

-- Logical Name => Ascii File,
-- Mode => Ada.Text IO.In File);
-- Files.Interactive_ Create (Which => "DECID",

-- Logical Name => Decid File,

-- Mode => Ada.Text IO.Out_File);

Files.Command Line Open create (Program Name => "asc2dcd.exe",
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Logical Src => Ascii file,
Logical_dest => Decid File,
Dest Extension => "dcd");

Sgml.Decid.Stag.Write (Tag => Sgml.Decid.Corpus, File => Decid File);
Sgml.Decid.Stag.Write (Tag => Sgml.Decid.Doc, File => Decid File);
Sgml.Decid.Stag.Write (Tag => Sgml.Decid.Text, File => Decid File);

Translate Each Segment (File => Ascii File);

Sgml.Decid.Etag.Write (Tag => Sgml.Decid.Text, File => Decid File);
Sgml.Decid.Etag.Write (Tag => Sgml.Decid.Doc, File => Decid File);
Sgml.Decid.Etag.Write (Tag => Sgml.Decid.Corpus, File => Decid File);

Ada.Text IO.Close (File => Ascii File);
Ada.Text_IO.Close (File => Decid File);

end Asc2dcd;

b) Detexte ASCII misen forme vers Corpus

with Ada.Text IO;

with Files;

with Segments.Sgml.Data;

with Segments.Sgml.Decid;

with Segments.Sgml.Decid.Etag;
with Segments.Sgml.Decid.Stag;
with Segments.Txt.Data;

with Segments.Txt.Laid Out Ascii;
with Segments.Txt.Meta;

procedure Csr2dcd is
use Segments;
Caesure_File, Decid File : Ada.Text IO.File Type ;

procedure Translate And Write (Object : in Txt.Data.Segment) is
begin

Sgml.Decid.Stag.Write (Tag => Sgml.Decid.Nls, File => Decid File);

Sgml.Data.Write (Object =>

Sgml.Data.Create (Content =>
Txt.Data.Get Content (Object => Object)),
File => Decid File);

Sgml.Decid.Etag.Write (Tag => Sgml.Decid.Nls, File => Decid File);

end Translate And Write;

procedure Nothing Done (Object : in Txt.Meta.Segment) is
begin

null;
end Nothing Done;



procedure Translate Each Segment is
new Txt.Laid Out_Ascii.For_ Each Segment G
(Action Data => Translate And Write,
Action Meta => Nothing Done) ;

begin

Files.Interactive Open (Which => "ASCII with caesure",
Logical Name => Caesure_ File,
Mode => Ada.Text_ IO.In File);
Files.Interactive_ Create (Which => "DECID",
Logical Name => Decid File,
Mode => Ada.Text IO.Out_File);

Sgml.Decid.Stag.Write (Tag => Sgml.Decid.Corpus, File => Decid File);

Sgml.Decid.Stag.Write (Tag => Sgml.Decid.Doc, File => Decid File);
Sgml.Decid.Stag.Write (Tag => Sgml.Decid.Text, File => Decid File);

Translate Each Segment (File => Caesure_ File);

Sgml.Decid.Etag.Write (Tag => Sgml.Decid.Text, File => Decid File);
Sgml.Decid.Etag.Write (Tag => Sgml.Decid.Doc, File => Decid File);
Sgml.Decid.Etag.Write (Tag => Sgml.Decid.Corpus, File => Decid File);

Ada.Text IO.Close (File => Caesure_File);
Ada.Text I0O.Close (File => Decid File);

end Csr2dcd;

c) DeHTML vers Corpus

with Ada.Characters.Latin_1;
with Ada.Exceptions;

with Ada.Text IO;

with Files;

with Lines;

with Logs;

with Paths;

with Segments.Sgml.Contexts_ G.Process_G;
with Segments.Sgml.Data;

with Segments.Sgml.Decid;

with Segments.Sgml.Decid.Contexts;

with Segments.Sgml.Decid.Etag;

with Segments.Sgml.Decid.Mixed;

with Segments.Sgml.Decid.Stag;

with Segments.Sgml.Html;
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with Segments.Sgml.Html.Contexts;
with Segments.Sgml.Html.Etag;
with Segments.Sgml.Html.Mixed;
with Segments.Sgml.Html.Stag;
with Sizes;
procedure Htm2dcd is

use Segments.Sgml;

Html File, Decid File : Ada.Text IO.File_ Type;

Html_ Context : aliased Html.Contexts.Tag Context;
Decid_ Context aliased Decid.Contexts.Tag_Context;

Title : Lines.Line;

Url : Paths.Path;

Alt : Lines.Line;

Space : Sizes.M Natural := 0;
Test : Boolean;

procedure Write Decid Stag (Object : in Decid.Stag.Segment) is
begin

Decid.Stag.Write (Object => Object, File => Decid File);
end Write Decid Stag;

procedure Write Decid Echo (Object : in Decid.Stag.Segment) is
begin
case Decid.Stag.Get Tag (Object) is
when Decid.Arr | Decid.Idea | Decid.Expr =>
Decid.Etag.Write_ Short
(Object => Decid.Mixed.Stag To Etag (Object),
File => Decid File);
when others =>
Decid.Etag.Write (Object => Decid.Mixed.Stag To Etag (Object),

File => Decid File);
end case; -- Decid.Stag.Get Tag (Object)
end Write Decid Echo;
procedure Write Decid Data (Object : in Data.Segment) is

begin
Data.Write (Object => Object,
Entities_Resolved => True,
File => Decid File);
end Write Decid Data;

procedure Do Nothing (Object : in Decid.Stag.Segment) is
begin
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null;
end Do _Nothing;

package Decid Process is new Decid.Contexts.Process_ G
(Action On_Virtual Opening => Do Nothing,

Action_On_Real Opening => Write Decid Stag,
Action On Virtual Closing => Do_Nothing,
Action_On_Real Closing => Write Decid Echo,
Action_On_Data => Write Decid Data) ;

procedure Actualize Title is
begin
Decid Process.Opening (Decid.Text) ;
if not Lines.Is_Empty (Title) then
Decid Process.Opening (Decid.Tit);
Decid Process.Actualize (Title);
Decid Process.Closing (Decid.Tit) ;
end if; -- not Lines.Is Empty (Title)
end Actualize Title;

procedure Translate Stag (Object : Html.Stag.Segment) is
begin
case Html.Stag.Get Tag (Object) is

when Html.Html =>
Decid Process.Opening (Decid.Doc) ;
Lines.Reset (Title);
Paths.Reset (Url);
Space := 0;

when Html.Body Side =>
Decid.Contexts.Reset Base (Decid Context) ;
Space := 0;

when Html.Heading =»>
Decid Process.Opening (Decid.Head) ;
Space := 0;

when Html.High Division | Html.Low Division =>
Decid Process.Opening (Object => Decid.Nls,
Maybe Done => True) ;
Space := 0;

when Html.Caesura =>
if Space > 1 then --2 is a threshold
Decid Process.Opening (Object =>

Decid.Contexts.Get_Base (Decid Context)) ;

Space := 0;
end if; -- Space > 1

when Html.List =>

parts)

Decid Process.Opening (Decid.Blck) ;
Space := 0;

when Html.Item =>
Decid Process.Opening (Decid.Item) ;
Space := 0;

when Html.Definiendum =>
Decid Process.Opening (Decid.Item) ;
Decid Process.Opening (Decid.Head) ;
Space := 0;

when Html.Definiens =>
Decid Process.Opening (Decid.Nls) ;
Space := 0;

when Html.Table =>
Decid Process.Opening (Decid.Scop) ;
Space := 0;

when Html.Caption =>
Decid Process.Opening (Decid.Meta) ;

Space := 0;
when Html.Header Side | Html.Title | -- not used but borders
Html.Row | Html.Header Cell | Html.Data Cell => --
Space := 0;
when Html.Dividing | Html.Base Url | Html.Alt Media =>
-- empty tags and mark tags, have been processed before
-- (as virtual)
null;
when Html.Code =>
null;
when Html.Other =>
null;
when Html.Null Tag => -- is not considered in procedure Opening
null;
end case; -- Html.Stag.Get Tag (Object)

end Translate Stag;

procedure Translate Etag (Object : Html.Stag.Segment) is
begin

case Html.Stag.Get Tag (Object) is

when Html.Html =>
Decid Process.Closing (Decid.Doc) ;

when Html.Body Side =>
Decid Process.Closing (Decid.Text) ;



when Html.Heading | Html.Definiendum =>
Decid Process.Closing (Decid.Head) ;

when Html.High Division | Html.Low Division =»>
Decid Process.Closing Base If Not Done;

when Html.List =»>
Decid Process.Closing (Decid.Blck) ;

when Html.Item =>
Decid Process.Closing (Decid.Item) ;

when Html.Definiens =>
Decid Process.Closing Base If Not_ Done;

when Html.Table =»>
Decid Process.Closing (Decid.Scop) ;

when Html.Caption =>
Decid Process.Closing (Decid.Meta) ;

when Html.Header Side | Html.Title | Html.Other | -- not used
Html.Row | Html.Header Cell | Html.Data Cell => -- (table
parts)
null;
when Html.Dividing | Html.Caesura | -- empty tags
Html.Base Url | Html.Alt Media => -- (used for attributes)
null;
when Html.Code =»>
null;
when Html.Null Tag => -- case processed by the basic
opening/closing
null;
end case; -- Html.Stag.Get Tag (Object)

end Translate Etag;
procedure Translate (Object in Data.Segment) is
begin
if Space = 1 then
Decid Process.Actualize (Lines.To_Decid String
(String’ (1 =>
Ada.Characters.Latin 1.Space)));
end i1if; -- Space =1
Space := 0;
case Html.Contexts.Get_ Present Context (Html Context) is
when Html.Title =>
Title :=
Lines.Append (Left => Title,
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Right =>
Data.Get_Content (Object => Object,
Entities Resolved =>
True)) ;
when Html.Code =>
null;
when others =>
Decid Process.Actualize (Object) ;
end case; -- Html.Contexts.Get Present Context (Html Context)
end Translate;
procedure Mark Tags_ Echo (Object in Html.Stag.Segment) is
begin
case Html.Stag.Get_ Tag (Object) is
when Html.Caesura =>
Space := Space +1;

when Html.Dividing =>
Decid Process.Opening (Decid.Contexts.Get Base
(Decid_Context)) ;
Space := 0;

when Html.Base Url =>
Html.Stag.Get Attribute (Object => Object,
Name => "HREF",
Value => Url,
Is_Present => Test);
if Test then
Decid Process.Opening (Decid.Arr);
Decid Process.Actualize (Lines.To Decid String ("URL")) ;
Decid Process.Closing (Decid.Arr);
Decid Process.Opening (Decid.Box) ;
Decid Process.Actualize (Lines.To_Decid String
(Paths.To_String (Url)));
Decid Process.Closing (Decid.Box) ;
end if; -- Test

when Html.Alt Media =>
Html.Stag.Get Attribute (Object => Object,
Name => "ALT",
Value => Alt,
Is_Present => Test);
if Test then

Alt := Lines.Append (Ada.Characters.Latin 1.Space, Alt);
Alt := Lines.Append (Alt, Ada.Characters.Latin 1.Space);
Decid Process.Actualize (Alt);

end if; -- Test

when Html.Body Side =>
Actualize Title;

when others =>
null;
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end case; -- Html.Stag.Get_Tag (Object) Ada.Text_ IO.Set Input (File => Html File);
end Mark_Tags_Echo; Ada.Text IO.Set Output (File => Decid File);
procedure Do_Not Forget Stored Data (Object : in Html.Stag.Segment) is Html Process.Init Context (Html_ Context’Access) ;
begin Decid Process.Init Context (Decid Context’Access) ;
if Html."=" (Html.Stag.Get_Tag (Object), Html.Html) then
-- if the tag <HTML> is virtually closed, that means that no SGML data Decid Process.Opening (Decid.Corpus) ;
-- segment was found Html Process.Opening (Html.Html) ;
Actualize Title;
end if; -- Html."=" (Html.Stag.Get_ Tag (Object), Html.Html) Interpret Each Segment (File => Html File);

end Do_Not_Forget_ Stored Data;
Html Process.Closing (Object => Html.Html, Maybe Done => True) ;
——————————————————————————————————————————————————————————————————————————— Decid_Process.Closing (Decid.Corpus) ;

package Html Process is new Html.Contexts.Process G Logs.Write (Message => "End of processing : if no other message, " &
(Action On Virtual Opening => Mark_Tags_Echo, "everything is OK.",
Action On_Real Opening => Translate_Stag, Ends_The Line => True);
Action On Virtual Closing => Do_Not Forget Stored Data,
Action On_Real Closing => Translate_ Etag, Ada.Text IO.Close (File => Html_File);
Action_On_Data => Translate) ; Ada.Text_IO.Close (File => Decid File);
exception

when E : others =>

procedure Html Process Closing (Object : Html.Etag.Segment) is Ada.Text IO.Put Line (File => Ada.Text IO.Standard Output,
begin Item => "htm2dcd Unhandled exception : " &
Html Process.Closing (Object => Object, Ada.Exceptions.Exception Name (E)) ;

Maybe Done => False);
end Html_Process_Closing;
end Htm2dcd;
procedure Html Process Opening (Object : Html.Stag.Segment) is
begin

Html Process.Opening (Object => Object,

Maybe Done => False);

end Html_Process_Opening;

procedure Read And Do is
new Html.Mixed.Action G (Action Data => Html_ Process.Actualize,
Action_Stag => Html Process_Opening,
Action_Etag => Html Process_Closing) ;

procedure Interpret Each Segment is
new Html.Mixed.For Each Segment G (Action => Read And Do) ;

begin
Files.Command Line Open create (Program Name => "htm2dcd.exe",
Logical_Src => Html File,
Logical_dest => Decid File,

Dest_ Extension => "dcd");




2. Leschainesdecaractéeres

a) Définition géenérique des chaines de caracteres
pour DECID

with Ada.Characters.Latin_ 1;
with Ada.Strings;

with Ada.Strings.Bounded;
with Ada.Strings.Maps;

with Ada.Text IO;

with Ada.Streams;

with Sizes;

generic
Size Group : Sizes.Size;

package Decid Strings G is
use Ada.Streams;
type Decid String is private;
Nasty Look : exception; -- = mal fichu !

Out_Of Bounds_Index : exception;
-- returned when dealing with character index
-- outside the real length of the Decid String
-- if the parameter Control Index is set to True,
-- and except for the case when upper bound < lower bound

Index_Should Be Controlled : constant Boolean;
-- fix the default value for parameter Control Index
-- cf. explanation of Out_Of Bounds_ Index exception in Decid_Strings.ads

Padding Character Default : Character
renames Ada.Characters.Latin 1.Space;

function Standard Max Size return Positive;

function Are The Same (Left, Right : in Decid String)
return Boolean;

function Are The Same (Left : in Decid String; Right : in String)
return Boolean;

function Are The Same (Left : in String; Right : in Decid_String)
return Boolean;

Null Constant : constant Decid String;
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function Null Decid String return Decid String;

the constant is usefull to give value to other constants ;
the function has the advantage to be automatically redefined
for every derived type.

function Is_Empty (Object : in Decid String) return Boolean;
procedure Reset (Object : in out Decid String);
function Size (Object : in Decid String) return Natural;

function To Decid String (Object : in String) return Decid String;
function To Decid String (Object : in Character) return Decid String;
function To String (Object : in Decid String) return String;

the first character of the Decid String gets the index 1.

function Append (Left, Right : in Decid String)
return Decid String;

function Append (Left : in Decid String; Right : in String)
return Decid String;

function Append (Left : in String; Right : in Decid String)
return Decid String;

function Append (Left : in Decid String; Right : in Character)
return Decid String;

function Append (Left : in Character; Right : in Decid String)
return Decid String;

function "&" (Left, Right : in Decid String)
return Decid String
renames Append;

function "&" (Left : in Decid String; Right : in String)
return Decid String
renames Append;

function "&" (Left : in String; Right : in Decid String)
return Decid String
renames Append;

function "&" (Left : in Decid String; Right : in Character)
return Decid String
renames Append;

function "&" (Left : in Character; Right : in Decid String)
return Decid String
renames Append;

function Get_ Character (Source : in Decid String;

Index : in Positive;

Control Index : in Boolean :=

Index Should Be Controlled) return Character;

-- the first character of the Decid String has always the position 1.
-- if Control Index is set to False and index out of bounds,
-- then the function returns the Null Character
-- (cf. constant Null Character in Decid Strings.adb) .
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function Get_String (Source : in Decid String;
From : in Positive;
To : in Natural;

Control Index : in Boolean :=
Index_Should Be_ Controlled) return String;
-- if From > To : return an empty string
-- else return the part of the Decid String between from and to
-- (its length can be different from To-From+1l ;
-- it can also be the empty string)

function Chunk (Source : in Decid String;
From : in Positive;
To : in Natural;

Control Index : in Boolean :=
Index_Should Be Controlled) return Decid_String;
-- if From > To : return an empty Decid String
-- else return the part of the Decid String between from and to
-- (its length can be different from To-From+1l ;
-- it can also be the empty Decid String)

function Replace (Source : in Decid String;
From : in Positive;
To : in Natural;
By : in Decid String;

Control_ Index : in Boolean :=
Index_Should Be_Controlled;
Padding Character : in Character :=
Padding Character_Default) return Decid String;

procedure Replace (Source : in out Decid String;
From : in Positive;
To : in Natural;
By : in Decid_String;
Control Index : in Boolean :=
Index_Should Be_ Controlled;
Padding Character : in Character :=
Padding Character Default) ;
-- for function and procedure Replace Slice,
-- nothing is done if From > To. Else
-- 1f they exist, characters of source between from and to are erased,
-- first character of By gets the position From,
-- if From > length of source, padding characters are inserted.

function Insert (Source : in Decid String;
At _Index : in Positive;
Object : in Decid String;
Control_ Index : in Boolean :=
Index_Should Be_Controlled;
Padding Character : in Character :=
Padding Character_Default) return Decid String;

procedure Insert (Source : in out Decid String;
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At_Index : in Positive;
Object : in Decid String;
Control Index : in Boolean :=
Index Should Be Controlled;
Padding Character : in Character :=
Padding Character Default) ;
-- first character of Object gets position At Index.
-- If At Index is greater than the length of Source
-- and Control Index set to False, then
-- padding characters are inserted.

function Delete (Source : in Decid_String;
From : in Positive;
To : in Natural;

Control Index : in Boolean :=
Index Should Be Controlled) return Decid String;

procedure Delete (Source : in out Decid String;
From : in Positive;
To : in Natural;

Control Index : in Boolean :=

Index Should Be Controlled) ;
-- for function and procedure Delete, nothing is done if From > To.
-- Else : characters between positions From and To are suppressed.

function Transliterate (Source : in Decid String;
Mapping : in Ada.Strings.Maps.Character Mapping)
return Decid String;

procedure Transliterate (Source : in out Decid String;
Mapping : in
Ada.Strings.Maps.Character Mapping) ;

function Has_ Characters (Object : in Decid String;
In Set : in Ada.Strings.Maps.Character Set)
return Boolean;

function Find String (Source : in Decid String;
Object : in String;
Going : in Ada.Strings.Direction :=

Ada.Strings.Forward;
Mapping : in Ada.Strings.Maps.Character Mapping
:= Ada.Strings.Maps.Identity) return Natural;

function Find String (Source : in Decid String;

Low Bound : in Positive;

High Bound : in Natural;

Object : in String;

Going : in Ada.Strings.Direction :=
Ada.Strings.Forward;

Mapping : in Ada.Strings.Maps.Character Mapping
:= Ada.Strings.Maps.Identity;

Control Index : in Boolean :=



Index_Should Be Controlled)

function Find Chunk (Source
Object
Going

return Natural;

in Decid String;
in Decid_String;

in Ada.Strings.Direction :=

Ada.Strings.Forward;

Mapping

Ada.Strings.Maps.Identity)

function Find Chunk (Source

Low_Bound
High Bound

Object

Going
Ada.Str

Mapping
Ada.Str

Control_ Index
Index_Should Be Controlled)
returns 0.

-- if Object is not found

procedure Find Pattern (Source
Set
Test

in Ada.Strings.Maps.Character Mapping :=
return Natural;

in Decid_String;
in Positive;
in Natural;
in Decid String;

in Ada.Strings.Direction :=

ings.Forward;

in Ada.Strings.Maps.Character Mapping :=
ings.Maps.Identity;

in Boolean :=

return Natural;

in Decid_String;
in Ada.Strings.Maps.Character Set;
in Ada.Strings.Membership :=

Ada.Strings.Inside;

Going

in Ada.Strings.Direction :=

Ada.Strings.Forward;

From

out Positive;

To : out Natural) ;

procedure Find Pattern (Source

Low_Bound
High Bound
in Ada.Strings.Maps.Character Set;

Set
Test

in Decid String;
in Positive;
in Natural;

in Ada.Strings.Membership :=

Ada.Strings.Inside;

Going

in Ada.Strings.Direction :=

Ada.Strings.Forward;

From

out Positive;

To : out Natural;

Control_ Index

in Boolean :=

Index Should Be Controlled) ;

-- if no token found

procedure Read (Object

File

From is set to 1 and To is set to 0.

out Decid String;
in Ada.Text IO.File Type :=

Ada.Text IO.Current Input) ;

private

package Base is new
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Ada.Strings.Bounded.Generic Bounded Length (Sizes.To Number
(Size Group)) ;

type Decid String is new Base.Bounded String;

procedure Write Stream Decid (Stream
Object

access Root_ Stream type’Class;
Decid string) ;

procedure Read Stream Decid (Stream
Object

access Root Stream type’Class;
out Decid string) ;

for Decid String’Write use Write_ Stream Decid;
for Decid String’read wuse Read Stream Decid;
Index Should Be Controlled constant Boolean := True;

Null Constant
Decid_String

constant Decid String :=
(Base.Null Bounded String) ;

end Decid Strings G;

with Logs;
package body Decid Strings G is

subtype Natural Range is Base.Length Range;
subtype Positive Range is Positive range 1..Base.Max Length;
Null Character Character renames Ada.Characters.Latin 1.NUL;
function Standard Max Size return Positive is
begin

return Sizes.To_ Number
end Standard Max Size;

(Notation => Size Group) ;

function Are The Same (Left, Right in Decid String)
return Boolean is
begin
return Left = Right;
end Are The Same;

function Are The Same (Left in Decid String; Right

return Boolean is

in String)
begin

return Left = Right;
end Are_The Same;
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function Are The Same (Left : in String; Right : in Decid String)
return Boolean is
begin
return Left = Right;
end Are The_ Same;

function Null Decid String return Decid String is
begin

return Null Constant;
end Null Decid String;

function Is Empty (Object : in Decid String) return Boolean is
begin

return Object = Null Decid String;
end Is_Empty;

procedure Reset (Object : in out Decid String) is
begin

Object := Null Decid_String;
end Reset;

function Size (Object : in Decid String) return Natural is
begin

return Length (Object);
end Size;

function To Decid String (Object : in String) return Decid String is
begin
return To Bounded String (Source=>Object, Drop=>Ada.Strings.Error) ;
exception
when Ada.Strings.Length Error =>
Logs.Write (Kind=>Logs.Warning,
Localization=>
"function Decid Strings.To_Decid String",
Exception Name=>"Ada.Strings.Length Error",
Propagated=>True,
Propagation Name=>"Decid Strings.Nasty Look") ;
Logs.Write (Data=>0bject) ;
raise Nasty Look;
end To Decid String;

function To Decid String (Object : in Character) return Decid String is
begin

return To_Decid String (String’ (1 => Object));
end To Decid String;
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function To_String (Object : in Decid String) return String is
begin

return Base.To_String(Base.Bounded String(Object)) ;
end To String;

function Append (Left, Right : in Decid String)
return Decid String is
begin
return Append (Left=>Left, Right=>Right, Drop=>Ada.Strings.Error) ;
exception
when Ada.Strings.Length Error =>
Logs.Write (Kind=>Logs.Warning,
Localization=>"function Decid Strings.Append",
Exception Name=>"Ada.Strings.Length Error",
Propagated=>True,
Propagation Name=>"Decid Strings.Nasty Look") ;
Logs.Write (Data=>To_ String(Left)) ;
Logs.Write (Data=>To_String(Right)) ;
raise Nasty Look;
end Append;

function Append (Left : in Decid String; Right : in String)
return Decid String is
begin
return Append (Left=>Left, Right=>Right, Drop=>Ada.Strings.Error) ;
exception
when Ada.Strings.Length Error =>
Logs.Write (Kind=>Logs.Warning,
Localization=>"function Decid Strings.Append",
Exception Name=>"Ada.Strings.Length Error",
Propagated=>True,
Propagation Name=>"Decid Strings.Nasty Look") ;
Logs.Write (Data=>To_String(Left)) ;
Logs.Write (Data=>Right) ;
raise Nasty Look;
end Append;

function Append (Left : in String; Right : in Decid String)
return Decid String is
begin
return Append (Left=>Left, Right=>Right, Drop=>Ada.Strings.Error) ;
exception
when Ada.Strings.Length Error =>
Logs.Write (Kind=>Logs.Warning,
Localization=>"function Decid Strings.Append",
Exception Name=>"Ada.Strings.Length Error",
Propagated=>True,
Propagation Name=>"Decid Strings.Nasty Look");
Logs.Write (Data=>Left) ;
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Logs.Write (Data=>To_String(Right)) ;
raise Nasty_ Look;
end Append;

function Append (Left in Decid_String; Right in Character)
return Decid String is
begin
return Append (Left=>Left, Right=>Right, Drop=>Ada.Strings.Error) ;
exception
when Ada.Strings.Length Error =>
Logs.Write (Kind=>Logs.Warning,
Localization=>"function Decid Strings.Append",
Exception Name=>"Ada.Strings.Length Error",
Propagated=>True,

Propagation Name=>"Decid_ Strings.Nasty Look") ;

Logs.Write (Data=>To_String(Left)) ;
raise Nasty_ Look;
end Append;

function Append (Left in Character; Right
return Decid String is

in Decid_ String)

begin
return Append (Left=>Left, Right=>Right, Drop=>Ada.Strings.Error) ;
exception
when Ada.Strings.Length Error =>
Logs.Write (Kind=>Logs.Warning,
Localization=>"function Decid Strings.Append",
Exception Name=>"Ada.Strings.Length Error",
Propagated=>True,
Propagation Name=>"Decid_ Strings.Nasty Look") ;
Logs.Write (Data=>To_String(Right)) ;
raise Nasty_ Look;
end Append;

function Get_ Character (Source in Decid_String;
Index in Positive;
Control_ Index in Boolean :=
Index_Should Be Controlled) return Character

begin

return Element (Source=>Source, Index=>Index) ;
exception

when Constraint Error => -- index < 1

case Control Index is
when True =>
pragma Debug (Logs.Write (Kind=>Logs.Trace,
Localization=>
"function

Decid_Strings.Get_ Character",

Exception_Name=>"Constraint_ Error",
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Propagated=>True,
Propagation Name=>

"Decid_Strings.Out_Of Bounds Index")) ;
pragma Debug (Logs.Write (Message=>"index = ",
Ends_The Line=>False));
pragma Debug (Logs.Write (Data=>Index)) ;
pragma Debug (Logs.Write (Message=>".",
Ends_The Line=>True)) ;
raise Out_ Of Bounds_Index;
when False =>
return Null Character;
end case;
when Ada.Strings.Index Error =>
case Control Index is
when True =>
pragma Debug (Logs.Write (Kind=>Logs.Trace,
Localization=>
"function
Decid_Strings.Get_ Character",
Exception Name=>
"Ada.Strings.Index Error",
Propagated=>True,
Propagation Name=>

"Decid_Strings.Out_Of Bounds Index")) ;
pragma Debug (Logs.Write (Message=>"index = ",

Ends_The Line=>False)) ;
pragma Debug (Logs.Write (Data=>Index)) ;
pragma Debug (Logs.Write (Message=>".",

Ends_The Line=>True)) ;
pragma Debug (Logs.Write(Data=>To String(Source))) ;
raise Out Of Bounds Index;

when False =>
return Null Character;
end case;
end Get Character;

function Get_ String (Source in Decid String;
From in Positive;
To : in Natural;
Control Index in Boolean :=
Index Should Be Controlled) return String is
Source_ Size Natural Range;
begin
case From > To is
when True =>

return "";
when False =>
Source Size := Length (Source) ;

case To > Source Size is
when True =>
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case Control Index is
when True =>
raise Out_Of Bounds_Index;
when False =>
case From > Source_ Size is
when True =>
return "";
when False =>
return Slice (Source=>Source,

Low=>From, High=>Source_Size) ;

end case; -- From > Source Size
end case; -- Control Index
when False =>
return Slice(Source=>Source, Low=>From, High=>To) ;
end case; -- To > Source Size
end case; -- From > To
exception
when Out_Of Bounds_Index =»>
pragma Debug (Logs.Write (Kind=>Logs.Trace,
Localization=>
"function Decid_Strings.Get_String",
Exception Name=>
"Decid Strings.Out_Of Bounds_Index",
Propagated=>True)) ;
pragma Debug (Logs.Write(Data=>To String(Source))) ;
raise;
end Get_ String;

function Chunk (Source : in Decid String;
From : in Positive;
To : in Natural;

Control Index : in Boolean :=
Index_Should Be Controlled) return Decid String is
begin
return To Decid String(Get_ String(Source=>Source,
From=>From,
To=>To,
Control_ Index=>Control_Index)) ;
exception
when Out_Of Bounds_Index =>
pragma Debug (Logs.Write (Kind=>Logs.Trace,
Localization=>
"function Decid Strings.Chunk",
Exception_Name=>
"Decid_Strings.Out_Of Bounds_Index",
Propagated=>True) ) ;
pragma Debug (Logs.Write(Data=>To_ String(Source))) ;
raise;
end Chunk;

function Mirror (Object : in Decid String) return Decid String is
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Result : Decid String := Null Decid String;

function Local Append(Left : in Decid String; Right : in Character)
return Decid String
renames Append;

begin
for Position in reverse 1..Size(Object) loop
Result := Local Append(Left=>Result,
Right=>Get_ Character (Source=>0bject,
Index=>Position)) ;
end loop; -- Position

return Result;
end Mirror;

procedure Mirror (Size : in Natural; Position : in out Natural) is
begin
if Position /= 0 then
if Position > Size then
raise Out Of Bounds Index;
end if;
Position := Size + 1 - Position;
end if;
exception
when Out_Of Bounds_ Index =>
pragma Debug (Logs.Write (Kind=>Logs.Trace,
Localization=>
"procedure Decid Strings.Mirror",
Exception Name=>
"Decid Strings.Out_Of Bounds_Index",
Propagated=>True)) ;
pragma Debug (Logs.Write (Message=>"index = ",
Ends_The Line=>False));
pragma Debug (Logs.Write(Data=>Position)) ;
pragma Debug (Logs.Write (Message=>".",
Ends_The Line=>True)) ;
pragma Debug (Logs.Write(Data=>To String(Source))) ;
raise Out Of Bounds Index;
end Mirror;

procedure Mirror (Size : in Natural;
One Position, Another Position : in out Positive) is
Position Memory : Positive;
begin
if One_Position > Size or Another Position > Size then
raise Out_ Of Bounds_Index;

end 1if;

Position Memory := One_ Position;

One Position := Size + 1 - Another Position;

Another Position := Size + 1 - Position Memory;
exception



when Out_Of Bounds_Index =>

pragma Debug (Logs.Write (Kind=>Logs.Trace,

Localization=>
"procedure Decid Strings.Mirror",
Exception_Name=>
"Decid_Strings.Out_Of Bounds_Index",

Propagated=>True)) ;

pragma Debug (Logs.Write (Message=>"Size of the string = ",
Ends_The Line=>False));

pragma Debug (Logs.Write(Data=>Size)) ;

pragma Debug (Logs.Write(Message=>" ; ",
Ends_The Line=>False)) ;

pragma Debug (Logs.Write(Message=>"index = ",
Ends_The Line=>False)) ;

pragma Debug (Logs.Write(Data=>One Position)) ;

pragma Debug (Logs.Write (Message=>" and ",
Ends_The Line=>False));

pragma Debug (Logs.Write(Data=>Another Position)) ;

pragma Debug (Logs.Write (Message=>".",
Ends_The Line=>True)) ;

raise Out_Of Bounds_Index;

end Mirror;

function Replace (Source in Decid String;
From : in Positive;
To : in Natural;
By : in Decid_String;
Control_ Index in Boolean :=
Index_Should Be Controlled;
Padding Character in Character :=
Padding Character Default) return Decid String is
Source_Size Natural Range;
begin
case From > To is
when True =>
return Source;
when False =>
Source Size := Length(Source) ;
case Control Index is
when True =>
case To > Source Size is
when True =>
raise Out_Of Bounds_Index;
when False =>
return Chunk (Source=>Source, From=>1, To=>From-1)
By & Chunk (Source=>Source,
From=>To+1, To=>Source Size) ;
end case; -- To > Source Size
when False =>
case From > Source_ Size is
when True =>
return Source &
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&

(From -1 - Source_Size)*Padding Character &
By;
when False =>
return Chunk (Source=>Source, From=>1, To=>From-1) &
By &
Chunk (Source=>Source,
From=>To+1, To=>Source Size,
Control_ Index=>False) ;
end case; -- From > Source Size
end case; -- Control Index
end case; -- From > To
exception
when Out Of Bounds Index =>
pragma Debug (Logs.Write (Kind=>Logs.Trace,
Localization=>
"subpgrm Decid Strings.Replace",
Exception Name=>
"Decid_Strings.Out_Of Bounds_ Index",
Propagated=>True)) ;
pragma Debug (Logs.Write(Data=>To String(Source))) ;
raise;
end Replace;

procedure Replace (Source in out Decid String;

From : in Positive;

To : in Natural;

By : in Decid_ String;

Control Index in Boolean :=
Index Should Be Controlled;

Padding Character in Character :=
Padding Character Default) is

begin
Source := Replace (Source=>Source,
From=>From, To=>To,
By=>By,

Control Index=>Control Index,
Padding Character=>Padding Character) ;
end Replace;

function Insert (Source in Decid String;
At_Index in Positive;
Object in Decid_ String;
Control Index in Boolean :=
Index Should Be Controlled;
Padding Character in Character :=
Padding Character Default) return Decid String is
Source_ Size Natural Range := Length (Source) ;
begin
case At_Index > Source_Size is
when True =>

case Control Index is
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when True =>
raise Out_Of Bounds_Index;
when False =>
return Source &
(At_Index -1 - Source_ Size)*Padding_ Character &
Object;
end case;
when False =>
return Chunk (Source=>Source, From=>1, To=>At Index-1) &
Object &
Chunk (Source=>Source, From=>At Index, To=>Source Size);
end case;
exception
when Out_Of Bounds_Index =»>
pragma Debug (Logs.Write (Kind=>Logs.Trace,
Localization=>
"subpgrm Decid Strings.Insert",
Exception Name=>
"Decid Strings.Out_Of Bounds_Index",
Propagated=>True)) ;
pragma Debug (Logs.Write(Message=>"index = ",
Ends_The Line=>False)) ;
pragma Debug (Logs.Write(Data=>At Index)) ;
pragma Debug (Logs.Write (Message=>".",
Ends_The Line=>True));
pragma Debug (Logs.Write(Data=>To_ String(Source))) ;
raise;
end Insert;

procedure Insert (Source in out Decid String;
At_Index in Positive;
Object in Decid String;
Control_ Index in Boolean :=
Index_Should Be_Controlled;
Padding Character in Character :=
Padding Character Default) is
begin
Source := Insert (Source=>Source, At Index=>At_Index, Object=>0Object,
Control_ Index=>Control Index,
Padding Character=>Padding Character) ;
end Insert;

function Delete (Source in Decid String;
From : in Positive;
To : in Natural;
Control_ Index in Boolean :=
Index_Should Be Controlled) return Decid String is
Source_Size Natural Range;
begin
case To < From is
when True =>
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return Source;
when False =>
Source Size := Length (Source) ;
case Control Index is
when True =>
case To > Source Size is
when True =>
raise Out_ Of Bounds_Index;
when False =>
return Chunk (Source=>Source, From=>1, To=>From-1)
Chunk (Source=>Source, From=>To+1,
To=>Source_Size) ;
end case; -- To > Source Size
when False =>
case From > Source_Size is
when True =>
return Source;
when False =>
return Chunk (Source=>Source, From=>1, To=>From-1)
Chunk (Source=>Source, From=>To+1,
To=>Source Size,
Control_ Index=>False) ;
end case; -- From > Source Size
end case; -- Control Index
end case; -- To < From
exception
when Out Of Bounds Index =>
pragma Debug (Logs.Write (Kind=>Logs.Trace,
Localization=>

"subpgrm Decid Strings.Delete",

Exception Name=>

"Decid Strings.Out_Of Bounds_Index",

Propagated=>True)) ;
pragma Debug (Logs.Write (Message=>"upper index = ",

Ends_The Line=>False));
pragma Debug (Logs.Write(Data=>To)) ;
pragma Debug (Logs.Write (Message=>".",

Ends_The Line=>True)) ;
pragma Debug (Logs.Write(Data=>To String(Source))) ;
raise;

end Delete;

procedure Delete (Source in out Decid String;
From : in Positive;
To : in Natural;
Control Index in Boolean :=
Index Should Be Controlled) is
begin
Source := Delete (Source=>Source, From=>From, To=>To,
Control Index=>Control Index) ;
end Delete;



function Transliterate (Source : in Decid String;

Mapping : in Ada.Strings.Maps.Character Mapping)

return Decid String is
begin
return Translate (Source=>Source, Mapping=>Mapping) ;
end Transliterate;

procedure Transliterate (Source : in out Decid String;
Mapping : in
Ada.Strings.Maps.Character Mapping) is
begin
Source := Transliterate (Source=>Source, Mapping=>Mapping) ;
end Transliterate;

function Has_Characters (Object : in Decid String;
In Set : in Ada.Strings.Maps.Character Set)
return Boolean is

function Is_Subset (Elements : in Ada.Strings.Maps.Character Set;
Set : in Ada.Strings.Maps.Character Set)
return Boolean
renames Ada.Strings.Maps.Is Subset;

function To Set (Sequence : in Ada.Strings.Maps.Character Sequence)
-- RM95 : subtype Character Sequence is String
return Ada.Strings.Maps.Character Set
renames Ada.Strings.Maps.To_Set;

begin
return Is Subset (Elements => To Set (Sequence => To_ String
(Object) ),
Set => In Set);
end Has_Characters;

function Find String (Source : in Decid String;
Object : in String;
Going : in Ada.Strings.Direction :=

Ada.Strings.Forward;
Mapping : in Ada.Strings.Maps.Character Mapping
:= Ada.Strings.Maps.Identity) return Natural is
begin
return Index (Source=>Source, Pattern=>Object,
Going=>Going, Mapping=s>Mapping) ;
end Find String;

function Find String (Source : in Decid String;
Low _Bound : in Positive;
High Bound : in Natural;
Object : in String;
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Going : in Ada.Strings.Direction :=
Ada.Strings.Forward;
Mapping : in Ada.Strings.Maps.Character Mapping
:= Ada.Strings.Maps.Identity;
Control Index : in Boolean :=
Index Should Be Controlled) return Natural is
Result : Natural;
begin
Result := Find String(Source=>Chunk (Source=>Source,
From=>Low_Bound,
To=>High Bound,
Control_ Index=>Control_ Index),
Object=>0bject,
Going=>Going,
Mapping=>Mapping) ;
case Result is
when 0 =>
return O;
when others =>
return Result + Low Bound -1;
end case;
end Find String;

function Find Chunk (Source : in Decid String;
Object : in Decid String;
Going : in Ada.Strings.Direction :=
Ada.Strings.Forward;
Mapping : in Ada.Strings.Maps.Character Mapping
:= Ada.Strings.Maps.Identity) return Natural is
begin
return Find String(Source=>Source, Object=>To_String(Object),
Going=>Going, Mapping=>Mapping) ;
end Find Chunk;

function Find Chunk (Source : in Decid String;
Low _Bound : in Positive;
High Bound : in Natural;
Object : in Decid String;
Going : in Ada.Strings.Direction :=
Ada.Strings.Forward;
Mapping : in Ada.Strings.Maps.Character Mapping
:= Ada.Strings.Maps.Identity;
Control Index : in Boolean :=
Index Should Be Controlled) return Natural is
begin
return Find String(Source=>Source,
Low_Bound=>Low_Bound, High Bound=>High Bound,
Object=>To_String (Object),
Going=>Going, Mapping=>Mapping,
Control_ Index=>Control Index) ;
end Find Chunk;
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procedure Find Pattern (Source : in Decid String;
Set : in Ada.Strings.Maps.Character Set;
Test : in Ada.Strings.Membership :=
Ada.Strings.Inside;
Going : in Ada.Strings.Direction :=
Ada.Strings.Forward;
From : out Positive;
To : out Natural) is
begin
case Going is
when Ada.Strings.Forward =>
Find_Token (Source=>Source, Set=>Set, Test=>Test,
First=>From, Last=>To);
when Ada.Strings.Backward =>
Find Token (Source=>Mirror (Source), Set=>Set, Test=>Test,
First=>From, Last=>ToO) ;
if To /= 0 then
Mirror (Size=>Size (Source),
One Position=>From, Another Position=>To) ;
end if; -- To /= 0
end case; -- Going
end Find Pattern;

procedure Find Pattern (Source : in Decid String;
Low_Bound : in Positive;
High Bound : in Natural;
Set : in Ada.Strings.Maps.Character Set;
Test : in Ada.Strings.Membership :=
Ada.Strings.Inside;
Going : in Ada.Strings.Direction :=
Ada.Strings.Forward;
From : out Positive;
To : out Natural;
Control Index : in Boolean :=
Index Should Be Controlled) is
Index Translation : Natural;
begin
Find Pattern (Source=>Chunk (Source=>Source,
From=>Low_Bound,
To=>High Bound,
Control_ Index=>Control Index),
Set=>Set,
Test=>Test,
Going=>Going,
From=>From,

To=>To) ;
if To > 0 then
Index Translation := Low_Bound -1;
From := From + Index Translation;
To := To + Index Translation;
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end 1if;
end Find Pattern;

procedure Read (Object : out Decid String;
File : in Ada.Text IO.File Type :=
Ada.Text IO.Current Input) is
Size : Natural;
Buffer : String (1..Standard Max Size +1);
begin
Ada.Text IO.Get_Line (File => File, Item => Buffer, Last => Size);
if Size = Buffer’Last then
raise Nasty Look;
else
Object := To Decid String (Buffer (1..Size));
end if;
exception
when Nasty Look =>
Logs.Write (Kind => Logs.Warning,
Localization => "Decid Strings G.Read",
Exception Name => "Decid Strings_G.Nasty Look",
Propagated => True) ;
Logs.Write (Data => Buffer);
raise;
end Read;

procedure Write Stream Decid (Stream : access Root_ Stream type’Class;
Object : Decid string) is
S : String := To_String (Object);
begin
Natural’Write (Stream, S’length);
String’Write (Stream, To String (Object));
end Write Stream Decid;

procedure Read Stream Decid (Stream : access Root Stream type’Class;
Object : out Decid string) is
S _Length : Natural;

begin
Object := Null Decid String;
Natural’read (Stream, S_length);
declare
S : String (1 .. S _Length);
begin
String’Read (Stream, S);
Object := To Decid String (S);
end ;

end read Stream Decid;

end Decid Strings G;



b) ngne function Get_Size (Object : in Generic_Identifier) return Natural;

function Is_Null (Object : in Generic_ Identifier) return Boolean;
with Decid_ Strings_G; ) ) ) ) ) )
with Sizes; function Find Gi (Source : in Lines.Line;

Object : in Generic Identifier;
package Lines is Going : in Ada.Strings.Direction) return Natural;
package Decid Strings is private

new Decid Strings G (Size Group => Sizes.L); . . .
- - - package Decid Strings is new
type Line is new Decid_Strings.Decid_String; Decid_Strings G (Size Group => Sizes.S);

Null Line : constant Line := Line (Decid Strings.Null Constant) ; type Gi_Name is new Decid_Strings.Decid_String;

type Generic_Identifier is new Ada.Finalization.Controlled with
record
Name : Gi_Name;

c) Chemin (nom complet d' un fichier) end record;

procedure Initialize (Object : in out Generic Identifier);

end Lines;

with Decid Strings_G;

with Sizes; procedure Adjust (Object : in out Generic Identifier);
package Paths is Null Gi : constant Generic Identifier :=
(Ada.Finalization.Controlled with
package Decid Strings is Name => Gi Name (Decid Strings.Null Constant)) ;

new Decid Strings_ G (Size Group => Sizes.M);
end Sgml Gis;
type Path is new Decid Strings.Decid String;

end Paths; ———=—=—=—=—=—=—=—=—=—=—=—=—=—=—=—=—=—=—=—=—=—=—=—=—=—=—=—=—=—=—=—=—=—=—=—=—=—=—=—=—=—=—=—=—=—=—=—=—=—=—=—=—=—=—=—=—=—=—=—=—=—=—=—=========

with Ada.Strings.Maps.Constants;

d) ldentifieur genéerique (en SGML) with Segments.Sgml;

package body Sgml Gis is
with Ada.Finalization; -

with Ada.Strings; procedure Initialize (Object : in out Generic Identifier) is
with Decid Strings_G; begin B
w%th L%nes; Object.Name :=
with Sizes; Transliterate (Source => Object.Name,
Mapping =>
package Sgml Gis is Ada.Strings.Maps.Constants.Upper Case_ Map) ;

end Initialize;
type Generic Identifier is private;

procedure Adjust (Object : in out Generic Identifier) is

Null Gi : constant Generic Identifier; begin
. . , . ) . L Object.Name :=
function To Gi (Object : in String) return Generic Identifier; Transliterate (Source => Object.Name,
, . . . o . Mapping =>
function Get Image (Object : in Generic Identifier) return String; Ada.Strings.Maps.Constants.Upper Case Map) ;
end Adjust; N -
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function To Gi (Object : in String) return Generic_Identifier is
begin
return (Ada.Finalization.Controlled with
Name => To_Decid String (Object));
end To Gi;

function Get_ Image (Object : Generic_ Identifier) return String is
begin

return To_String (Object.Name) ;
end Get Image;

function Get Size (Object : in Generic_ Identifier) return Natural is
begin

return Size (Object.Name) ;
end Get_Size;

function Is _Null (Object : in Generic_Identifier) return Boolean is
begin

return Is_Empty (Object.Name) ;
end Is Null;

function Find Gi (Source : in Lines.Line;
Object : in Generic_ Identifier;
Going : in Ada.Strings.Direction) return Natural is
begin
return Segments.Sgml.Find Name (Source => Source,
Object => Get_Image (Object),
Going => Going,
Mapping =>

Ada.Strings.Maps.Constants.Upper Case Map) ;
end Find Gi;

end Sgml Gis;
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3. Lessegments

a) Eléments généraux de définition

with Ada.Characters.Latin 1;
with Ada.Strings.Maps;

with Ada.Strings.Maps.Constants;
with Lines;

package Segments is
type Segment Level is (Meta, Data);

private

function "and" (Left, Right : in Ada.Strings.Maps.Character Set)
return Ada.Strings.Maps.Character Set
renames Ada.Strings.Maps."and";

function "or" (Left, Right : in Ada.Strings.Maps.Character Set)
return Ada.Strings.Maps.Character Set
renames Ada.Strings.Maps."or";

function "not" (Right : in Ada.Strings.Maps.Character Set)
return Ada.Strings.Maps.Character Set
renames Ada.Strings.Maps."not";

No_Spacing Set : constant Ada.Strings.Maps.Character Set :=
(Ada.Strings.Maps.Constants.Control Set
or Ada.Strings.Maps.To_Set (Ada.Characters.Latin 1.Grave) -- 96
or Ada.Strings.Maps.To_Set (Ada.Characters.Latin 1.Acute)) -- 180
and not Ada.Strings.Maps.To_ Set (Ada.Characters.Latin 1.HT);

Spacing Set : constant Ada.Strings.Maps.Character_ Set :=
Ada.Strings.Maps.To Set (Ada.Characters.Latin 1.HT)
or Ada.Strings.Maps.To_Set (Ada.Characters.Latin 1.Space)
or Ada.Strings.Maps.To_ Set (Ada.Characters.Latin 1.No Break Space) ;

No Sign Set : constant Ada.Strings.Maps.Character Set :=
Ada.Strings.Maps.Constants.Control Set
or Ada.Strings.Maps.To Set (Ada.Characters.Latin 1.Space)
or Ada.Strings.Maps.To_Set (Ada.Characters.Latin 1.No Break Space) ;



procedure Clean (Data
Garbage

procedure Clean (Data
Garbage
Replace

procedure Clean_ Input (D
function Is_Significant
-- call Clean_ Input (Object

end Segments;

out Lines.Line;
in Ada.Strings.Maps.Character Set);

in

in out Lines.Line;
in Ada.Strings.Maps.Character Set;
ment in Character) ;

ata in out Lines.Line) ;

(Object in Lines.Line)
return Boolean;
) before.

Simplify Characters Map

(Ada.Characters
Ada.Characters
Ada.
Ada.
Ada.
Ada.

.Latin
.Latin__
Characters.Latin_
Characters.Latin
Characters.Latin_
Characters.Latin

(Data
Garbage

Positive;
Natural;

procedure Clean

Low
High

begin
loop
Lines.Find Pattern

exit when High = 0;

Lines.Delete (Sourc
end loop;
end Clean;

constant Ada.Strings.Maps.Character Mapping :=
Ada.Strings.Maps.To_Mapping

1.Left_Angle Quotation & -- 171
1.Right Angle Quotation & -- 187
1.Soft Hyphen, -- 173
1.Quotation & -- 34

1.Quotation &

1.Hyphen) ; -- 45

in out Lines.Line;
in Ada.Strings.Maps.Character Set)

(Source => Data,

Set => Garbage,

Test => Ada.Strings.Inside,
Going => Ada.Strings.Forward,
From => Low,

To => High) ;

e => Data,

From => Low, To => High);

procedure Clean (Data in out Lines.Line;
Garbage in Ada.Strings.Maps.Character Set;
Replacement in Character) is
Low Positive;
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is

High Natural;

Cleaned Lines.Line := Lines.Null Decid String;

function "&" (Left in Lines.Line; Right in String)
return Lines.Line

renames Lines."&";

function "&" (Left in Lines.Line; Right in Character)

return Lines.Line
renames Lines."&";

begin
loop
Lines.Find Pattern(Source => Data,
Set => Garbage,
Test => Ada.Strings.Inside,
Going => Ada.Strings.Forward,
From => Low,
To => High) ;
exit when High = 0;
Cleaned := Cleaned &
Lines.Get_ String(Source => Data,
Replacement;
Data := Lines.Chunk (Source => Data,
From => High+1,
To => Lines.Size(Data)) ;

From => 1, To => Low-1) &

end loop;
Data := Lines.Append(Left => Cleaned, Right => Data);
end Clean;

procedure Clean Input is
begin

Clean (Data =>

Garbage
Clean(Data => Data,

Garbage => Spacing_ Set,

Replacement => Ada.Characters.Latin 1.Space);
Lines.Transliterate (Source => Data,

Mapping => Simplify Characters Map) ;

(Data in out Lines.Line)

Data,
=> No_Spacing Set) ;

end Clean Input;

(Object in Lines.Line)
return Boolean is

function Is_Significant

begin
return not (Lines.Is Empty (Object) or
Lines.Are The Same (Object,

String’ (1 =>

Ada.Characters.Latin 1.Space)));
end Is_Significant;
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Segment detypedata: le contenu d’un alinéa

end Segments; with Ada.Text IO;
with Lines;
b) Lessegmentsdanslesfichierstexte (.txt) package Segments.Txt.Data is
type Segment is new Segments.Txt.Segment with private;
Base de définition dessegments function Create (Content : in Lines.Line)

return Segment;
with Ada.Text IO;

with Lines; procedure Write (Object : in Segment;
File : in Ada.Text IO.File Type :=
package Segments.Txt is Ada.Text_ IO.Current Output) ;
type Segment is abstract tagged private; function Get_Level (Object : in Segment)
return Segments.Segment Level;
procedure Write (Object : in Segment;
File : in Ada.Text IO.File Type := function Get_Content (Object : in Segment)
Ada.Text_ IO.Current Output) return Lines.Line;
is abstract;
function Test Content (Object : in Segment;
function Get Level (Object : in Segment) Value : in Lines.Line := Lines.Null Decid String)
return Segments.Segment_Level return Boolean;
is abstract;
procedure Set Content (Object : in out Segment;
private Value : in Lines.Line) ;
type Segment is abstract tagged null record; private
procedure Set Segment (Object : in out Segment) ; type Segment is new Segments.Txt.Segment with
record
end Segments.Txt; Content : Lines.Line := Lines.Null Decid String;

end record;

procedure Set Segment (Object : in out Segment;

Content : in Lines.Line) ;
with Ada.Characters.Latin 1;
with Ada.Strings.Maps; end Segments.Txt.Data;

with Ada.Strings.Maps.Constants;

package body Segments.Txt is

procedure Set Segment (Object : in out Segment) is package body Segments.Txt.Data is
begin
null; T T T T T T T oo
end Set Segment;
function Get Level (Object : in Segment)
end Segments.Txt; return Segments.Segment Level is
begin

return Segments.Data;



end Get Level;

function Get Content (Object in Segment)
return Lines.Line is
begin
return Object.Content;
end Get Content;

function Test Content (Object in Segment;
Value in Lines.Line := Lines.Null Decid String)
return Boolean is
begin
return Lines.Are The Same (Get_Content (Object), Value);
end Test_ Content;

procedure Set Content (Object
Value

in out Segment;
in Lines.Line) is
begin

Object.Content := Value;
end Set_Content;

procedure Set_ Segment (Object
Content

in out Segment;

in Lines.Line) 1is

begin
Set Segment (Object => Segments.Txt.Segment (Object)) ;
Set_Content (Object => Object, Value => Content) ;

end Set Segment;

function Create (Content in Lines.Line)
return Segment is
Result Segment ;
begin
Set Segment (Object => Result, Content => Content) ;
return Result;
end Create;

procedure Write (Object in Segment;
File : in Ada.Text IO.File Type :=
Ada.Text_ IO.Current Output) is
begin
Ada.Text IO.Put (File => File,
Item => Lines.To_String (Get_Content (Object)));
end Write;

end Segments.Txt.Data;
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Segment detype méta : séparation structurante

with Sizes;
package Segments.Txt.Meta is
type Segment is new Segments.Txt.Segment with private;
type Separator Kind is (Vertical Space, Horizontal Space) ;
subtype Separator Size is Sizes.S Natural;
function Create (Separator in Separator Kind;
Size : in Separator Size)
return Segment;
procedure Write (Object in Segment;
File : in Ada.Text IO.File Type :=

Ada.Text_ IO.Current Output) ;

function Get_ Level (Object in Segment)
return Segments.Segment Level;

function Get Separator (Object in Segment)
return Separator Kind;

procedure Set Separator (Object
Value

in out Segment;
in Separator Kind) ;

function Get Size (Object in Segment)
return Separator Size;

procedure Set Size (Object
Value

in out Segment;
in Separator Size) ;

private

type Segment is new Segments.Txt.Segment with

record
Separator Separator Kind := Vertical Space;
Size : Separator Size := 0;

end record;

procedure Set Segment (Object in out Segment;
Separator in Separator Kind;
Size : in Separator Size);

end Segments.Txt.Meta;
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package body Segments.Txt.Meta is

function Get Level (Object : in Segment)
return Segments.Segment Level is
begin
return Segments.Meta;
end Get_Level;

function Get_ Separator (Object : in Segment)
return Separator Kind is
begin
return Object.Separator;
end Get_Separator;

procedure Set_ Separator (Object : in out Segment;
Value : in Separator Kind) is
begin
Object.Separator := Value;

end Set_Separator;

function Get_Size (Object : in Segment)
return Separator Size is
begin

return Object.Size;
end Get_Size;

procedure Set_Size (Object : in out Segment;
Value : in Separator Size) is
begin
Object.Size := Value;

end Set_Size;

procedure Set_ Segment (Object : in out Segment;
Separator : in Separator Kind;
Size : in Separator Size) is
begin

Set_Segment (Object => Segments.Txt.Segment (Object)) ;
Set Separator (Object => Object, Value => Separator);
Set_Size (Object => Object, Value => Size);

end Set Segment;

function Create (Separator : in Separator Kind;
Size : in Separator Size)
return Segment is
Result : Segment;
begin
Set_Segment (Object => Result,
Separator => Separator, Size => Size);
return Result;
end Create;
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procedure Write (Object : in Segment;
File : in Ada.Text IO.File Type :=
Ada.Text IO.Current Output) is
begin
Ada.Text_ IO.New Line(File => File);
Ada.Text IO.New_Line(File => File);
end Write;

end Segments.Txt.Meta;

Par cours des segments d’un fichier textesimple

with Ada.Text IO;
with Segments.Txt.Data;

package Segments.Txt.Plain Ascii is
generic
with procedure Action (Object : in Segments.Txt.Data.Segment) ;

procedure For Each Segment G (File : in out Ada.Text IO.File Type);

end Segments.Txt.Plain Ascii;

with Ada.Characters.Latin 1;
with Lines;

package body Segments.Txt.Plain Ascii is

function Is Significant (Input : in Lines.Line) return Boolean is
begin
return not (Lines.Are The Same (Input, Lines.Null Decid String) or
Lines.Are The Same (Input,
String’ (1 =>

Ada.Characters.Latin 1.Space)));
end Is_Significant;

function Read (File : in Ada.Text IO.File_ Type)
return Segments.Txt.Data.Segment is
Input : Lines.Line;
begin
while not Ada.Text IO.End Of File (File => File) loop
Lines.Read (File => File, Object => Input);
Segments.Clean_ Input (Input);
exit when Is Significant (Input);
end loop; -- while not ...End Of File...
return Segments.Txt.Data.Create (Content => Input) ;
end Read;



-- generic
-- with procedure Action (Object : in Segments.Txt.Data.Segment) ;
procedure For Each Segment G (File : in out Ada.Text IO.File Type) is
begin
Ada.Text IO.Reset (File => File, Mode => Ada.Text IO.In File);
while not Ada.Text IO.End Of File (File) loop
Action (Read (File => File));
end loop; -- while not ...End Of File...
end For_ Each Segment G;

end Segments.Txt.Plain Ascii;

Par cour s des segments d’un fichier texte misen forme

with Ada.Text IO;

with Polymorphic Objects G;
with Lines;

with Segments.Txt.Data;
with Segments.Txt.Meta;

use Segments.Txt.Data;
use Segments.Txt.Meta;

package Segments.Txt.Laid Out Ascii is

package Polymorphic_Objects is new
Polymorphic Objects G (Object Root => Segments.Txt.Segment) ;

subtype Segment is Polymorphic Objects.Polymorphic Object;

function To_Segment is new
Polymorphic Objects.To_ Polymorphic G (Object Child =»>
Segments.Txt.Data.Segment) ;

function To_Segment is new
Polymorphic Objects.To_ Polymorphic G (Object Child =»>
Segments.Txt .Meta.Segment) ;
function To_Data is new
Polymorphic_Objects.To_Child G (Object_Child =>
Segments.Txt.Data.Segment) ;
function To_Meta is new
Polymorphic_Objects.To_Child G (Object_ Child =»>
Segments.Txt.Meta.Segment) ;
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procedure Write (Object : in Segments.Txt.Laid Out_ Ascii.Segment;
File : in Ada.Text IO.File Type :=
Ada.Text_ IO.Current Output) ;

function Get Level (Object : in Segments.Txt.Laid Out_ Ascii.Segment)
return Segments.Segment Level;

function Get Content is new
Polymorphic Objects.Child Function G (Object Child =>
Segments.Txt .Data.Segment,
Result Type => Lines.Line,
Action =>

Segments.Txt.Data.Get Content) ;

procedure Set Content is new
Polymorphic Objects.Child Procedure G (Object_ Child =>
Segments.Txt .Data.Segment,
Value Type => Lines.Line,
Action =>

Segments.Txt.Data.Set Content) ;

function Get Separator is new
Polymorphic Objects.Child Function G (Object Child =>
Segments.Txt .Meta.Segment,
Result Type =>

Segments.Txt .Meta.Separator Kind,
Action =>

Segments.Txt.Meta.Get Separator) ;

procedure Set Separator is new
Polymorphic Objects.Child Procedure G (Object_ Child =»>
Segments.Txt .Meta.Segment,
Value Type =>

Segments.Txt .Meta.Separator Kind,
Action =>

Segments.Txt.Meta.Set Separator) ;
function Get_Size is new
Polymorphic Objects.Child Function G (Object Child =>

Segments.Txt .Meta.Segment,
Result Type =>
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Segments.Txt .Meta.Separator_Size,
Action =>
Segments.Txt.Meta.Get_Size);

procedure Set Size is new
Polymorphic_Objects.Child Procedure G (Object_ Child =»>
Segments.Txt .Meta.Segment,
Value Type =>

Segments.Txt.Meta.Separator Size,
Action =>
Segments.Txt .Meta.Set Size);

generic
with procedure Action Data (Object : in Segments.Txt.Data.Segment) ;
with procedure Action Meta (Object : in Segments.Txt.Meta.Segment) ;
procedure For Each Segment G (File : in out Ada.Text IO.File_ Type);

end Segments.Txt.Laid Out Ascii;

with Ada.Characters.Latin 1;
with Ada.Strings.Maps;
with Lines;

iis

H-

package body Segments.Txt.Laid Out Asc

procedure Write (Object : in Segments.Txt.Laid Out_Ascii.Segment;
File : in Ada.Text IO.File Type :=
Ada.Text_ IO.Current Output) is
begin
Write (Object => Polymorphic Objects.Get Details (Object) .all,
File => File);
end Write;

function Get Level (Object : in Segments.Txt.Laid Out Ascii.Segment)
return Segments.Segment Level is
begin
return Get_ Level (Polymorphic Objects.Get Details (Object) .all);
end Get Level;

Null Segment : Segments.Txt.Laid Out_Ascii.Segment :=

ANNEXE V.3

To Segment (Segments.Txt.Data.Create (Content =>

Lines.Null Decid String));

function Has_Signs (Data : in Lines.Line) return Boolean is
begin
return not (Lines.Are The Same (Data, Lines.Null Decid String)
or Lines.Are The_ Same (Data,
String’ (1 =>

Ada.Characters.Latin 1.Space)));

end Has_ Signs;

function Has_Blank Beginning (Data : in Lines.Line) return Boolean
begin
return Lines.Get Character (Source => Data, Index => 1) =
Ada.Characters.Latin 1.Space;
end Has_Blank Beginning;

procedure Read (Current_ Segment
in out Segments.Txt.Laid Out_ Ascii.Segment;
File : in Ada.Text IO.File Type :=
Ada.Text IO.Current Input;
Next_ Segment
out Segments.Txt.Laid Out_ Ascii.Segment) is
Data Input, Current Content : Lines.Line;

function "&" (Left, Right : in Lines.Line)
return Lines.Line
renames Lines."&";

function "&" (Left : in Lines.Line; Right : in Character)
return Lines.Line
renames Lines."&";

begin
case Get_Level (Current Segment) is
when Segments.Data =>
loop
if Ada.Text IO.End Of File (File => File) then
Next Segment :=
To Segment (Segments.Txt.Meta.Create
(Separator =>
Segments.Txt.Meta.Vertical Space,
Size => 0));
exit;
end if; -- Ada.Text IO.End Of File (File => File)
Lines.Read (File => File, Object => Data Input);
Segments.Clean Input (Data_ Input) ;
case Has Signs (Data Input) is
when True =>
Current Content := Get Content (Current Segment) ;
case Ada.Strings.Maps.Is_In
(Element =>



Lines.Get_Character (Source => Current_ Content,
Index =>
Lines.Size
(Current_Content)),
Set => Segments.Spacing Set)
is
when True =>
Set_Content (Object => Current_ Segment,
Value => Current_ Content &
Data_Input) ;
when False =>
Data_ Input :=
(Get_Content (Current Segment) &
Ada.Characters.Latin 1.Space) &
Data_ Input;
Set_Content (Object => Current_ Segment,
Value => Data Input);
end case; -- ...Is_In (...Spacing Set)
when False =>
Next_ Segment :=
To_Segment (Segments.Txt.Meta.Create
(Separator =>
Segments.Txt.Meta.Vertical Space,
Size => 1)) ;

exit;
end case; -- Has_Signs (Data_Input)
end loop;
when Segments.Meta =>
loop

if Ada.Text IO.End Of File (File => File) then
Next_ Segment :=
To_Segment (Segments.Txt.Meta.Create
(Separator =>
Segments.Txt.Meta.Vertical_ Space,
Size => 0));
exit;
end if; -- Ada.Text IO.End Of File (File => File)
Lines.Read (File => File, Object => Data Input);
Segments.Clean Input (Data Input) ;
case Has_Signs (Data_Input) is
when True =>
if Has_ Blank Beginning (Data_Input) then
Lines.Delete (Source => Data Input,
From => 1, To => 1);
end if; -- Has_Blank Beginning (Data_Input)
Next_ Segment :=
To_Segment (Segments.Txt.Data.Create (Content =»>

Data Input));
exit;
when False =>
Set_Size (Object => Current_ Segment,
Value => Get_Size (Current_Segment) + 1);

643

end case; -- Has Signs (Data_ Input)
end loop;
end case; -- Get Level (Current Segment)
end Read;

procedure Read First (Current Segment
out Segments.Txt.Laid Out Ascii.Segment;
File : in Ada.Text IO.File Type :=
Ada.Text_ IO.Current_ Input;
Next Segment
out Segments.Txt.Laid Out Ascii.Segment) is

Data_ Input : Lines.Line;

begin
Lines.Read (File => File, Object => Data Input);
Segments.Clean Input (Data Input) ;
case Has Signs (Data Input) is
when True =>
case Has Blank Beginning (Data_ Input) is
when True =>
Current_Segment :=
To_Segment (Segments.Txt.Meta.Create
(Separator =>
Segments.Txt .Meta.Horizontal Space,
Size => 0));
Next Segment :=
To Segment (Segments.Txt.Data.Create
(Content =>
Lines.Delete (Source =>
Data_ Input,
From => 1,
To => 1)));
when False =>
Current_ Segment :=
To Segment (Segments.Txt.Data.Create (Content =>
Data_ Input)) ;
Read (Current Segment => Current Segment,
File => File,
Next Segment => Next Segment) ;
end case; -- Has_Blank Beginning (Data_Input)
when False =>
Current_ Segment :=
To Segment (Segments.Txt.Meta.Create
(Separator =>
Segments.Txt.Meta.Vertical Space,
Size => 1));
case Ada.Text IO.End Of File (File) is
when True =>
Next Segment :=
To_Segment (Segments.Txt.Meta.Create
(Separator =>
Segments.Txt.Meta.Vertical Space,
Size => 0));
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when False =>
Read (Current_Segment => Current_ Segment,
File => File,
Next Segment => Next Segment) ;
end case; -- Ada.Text IO.End Of File (File)
end case; -- Has_Signs(Data_Input)
end Read First;

-- generic
-- with procedure Action Data (Object
-- with procedure Action Meta (Object
procedure For Each Segment G (File
Current Segment, Next Segment

in Segments.Txt.Data.Segment) ;

in Segments.Txt.Meta.Segment) ;
in out Ada.Text IO.File Type) is

Segments.Txt.Laid Out_Ascii.Segment;

procedure Action is
begin
case Get Level (Current Segment) is
when Segments.Data =>
Action Data (To_Data (Current_Segment)) ;
when Segments.Meta =>
Action Meta (To_Meta (Current_Segment)) ;
end case; -- Get_Level (Current_ Segment)
Current Segment := Next Segment;
end Action;

begin
Ada.Text IO.Reset (File => File, Mode => Ada.Text IO.In File);
if not Ada.Text IO.End Of File (File => File) then
-- First segment
Read First (Current_Segment => Current_ Segment,
File => File,
Next Segment => Next Segment) ;
Action;
-- Following segments
while not Ada.Text IO.End Of File(File) loop
Read (Current_Segment => Current_ Segment,
File => File,
Next Segment => Next Segment) ;
Action;
end loop; -- while not
-- Last segment
case Get_Level (Current_Segment) is
when Segments.Data =>
Action Data (To_Data (Current_ Segment)) ;
when Segments.Meta =>
Action Meta (To_Meta (Current_ Segment)) ;
end case; -- Get_Level (Current_Segment)
end if; -- if not ...End Of File...
end For_Each Segment_ G;

...End Of File...

end Segments.Txt.Laid Out Ascii;
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c) Lessegmentsdanslesfichiers SGML

Base de définition des segments

with Ada.Characters.Latin 1;
with Ada.Strings.Maps;

with Ada.Strings.Maps.Constants;
with Ada.Text IO;

with Lines;

package Segments.Sgml is
use Ada;
type Segment is abstract tagged private;

Syntax Error exception;
procedure Write (Object in Segment;
File : in Text IO.File Type :=
Text IO.Current Output)
is abstract;

function Get Level (Object in Segment)
return Segments.Segment Level
is abstract;

function Is Like Name (Object in String) return Boolean;
procedure Find Name

(Source : in Lines.Line;

From : out Positive;

To : out Natural;

Going : in Strings.Direction := Strings.Forward) ;

function Find Name
(Source : in Lines.Line;
Object : in String;
Going : in Strings.Direction := Ada.Strings.Forward;
Mapping : in Strings.Maps.Character Mapping := Strings.Maps.Identity)
return Natural;

private

type Segment is abstract tagged null record;



procedure Set Segment (Object : in out Segment) ;

Stago : constant String :=
- ||<||’.
String’ (1=>Ada.Characters.Latin 1.Less_Than_Sign) ;
-- SGML "start-tag open"

Etago : constant String :=
- ||</||’.
String’ (1=>Ada.Characters.Latin 1.Less_Than Sign,
2=>Ada.Characters.Latin_1.Solidus) ;
-- SGML "end-tag open"

Tagc : constant String :=
— l|>l|’.
String’ (1=>Ada.Characters.Latin 1.Greater_Than Sign) ;
-- SGML "tag close"

-- Characters sets --

function "or" (Left, Right : in Ada.Strings.Maps.Character Set)
return Ada.Strings.Maps.Character_ Set
renames Ada.Strings.Maps."or";

Name Character Set : constant Ada.Strings.Maps.Character Set :=
Ada.Strings.Maps.Constants.Alphanumeric_Set
or Ada.Strings.Maps.To_Set (Ada.Characters.Latin_ 1.Full_Stop)
or Ada.Strings.Maps.To_Set (Ada.Characters.Latin 1.Hyphen) ;

Name_ Start Character Set : constant Ada.Strings.Maps.Character Set :=
Ada.Strings.Maps.Constants.Basic_Set;
-- SGML states that Name Start Character Set is a subset of
Name_Character_ Set.

Digit Set : constant Ada.Strings.Maps.Character Set :=
Ada.Strings.Maps.Constants.Decimal Digit_Set;

end Segments.Sgml;

with Ada.Strings;
with Decid Maps;
with Logs;

package body Segments.Sgml is
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procedure Set Segment (Object : in out Segment) is
begin

null;
end Set Segment;

function Is Like Name (Object : in String) return Boolean is
begin
case Object’Length is
when 0 =>
return False;
when others =>
return
Ada.Strings.Maps.Is_In (Element => Object (Object’First),
Set => Name Start Character Set)
and
Decid Maps.Has_ Characters (Object =>
Object
(Object’First+1..0bject’Last),
In Set => Name_ Character Set);

end case; -- Object’Length
end Is_Like Name;
procedure Find With First Character (Source : in Lines.Line;
First_ Character_ Set
in

Ada.Strings.Maps.Character Set;
Following Characters_Set
in
Ada.Strings.Maps.Character Set;
From : out Positive;
To : out Natural;
Going : in Ada.Strings.Direction :=
Ada.Strings.Forward) is
Low : Positive;
begin
Lines.Find Pattern (Source => Source,
Set => First Character Set,
Test => Ada.Strings.Inside,
Going => Going,
From => From,
To => To);
if To > 0 then
case Going is
when Ada.Strings.Forward =>
Lines.Find Pattern (Source =>
Lines.Delete (Source => Source,
From => 1,
To => From),
Set => Following Characters_Set,
Test => Ada.Strings.Inside,
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Going => Ada.Strings.Forward, begin
From => Low, Find With First Character (Source => Source,
To => To) ; First_ Character Set =>
case Low = 1 is Name_ Start Character Set,
when True => Following Characters_Set =>
To := To + From; Name_ Character Set,
when False => From => From,
To := From; To => To,
end case; -- Low = 1 Going => Going) ;
when Ada.Strings.Backward => end Find Name;
Low := To;
Lines.Find Pattern (Source => Source, function Find Name (Source : in Lines.Line;
Set => Following Characters_Set, Object : in String;
Test => Ada.Strings.Inside, Going : in Ada.Strings.Direction :=
Going => Ada.Strings.Backward, Ada.Strings.Forward;
From => From, Mapping : in Ada.Strings.Maps.Character Mapping :=
To => To); Ada.Strings.Maps.Identity)
case From <= Low +1 and Low <= To is return Natural is
when True => Low, High : Natural;
case From > 1 is begin
when True => if not Is_Like Name (Object) then
Lines.Find Pattern Logs.Write (Kind => Logs.Warning,
(Source => Lines.Delete (Source => Source, Localization => "function Segments.Sgml.Find Name") ;
From => 1, Logs.Write (Message => "The string " & Object &
To => From -2), " to be searched is not a SGML name " &
Set => First_ Character Set, "([A-Za-2z] [0-9A-Za-z.-1*).",
Test => Ada.Strings.Inside, Ends The Line => True);
Going => Ada.Strings.Forward, end if;
From => From, Low := Lines.Find String (Source => Source, Object => Object,
To => Low) ; Going => Going, Mapping => Mapping) ;
when False => if Low > 0 then -- checking of the borders : Object should not be
Lines.Find Pattern (Source => Source, -- the part of a name in Source
Set => First Character Set, High := Low + Object’Length;
Test => Ada.Strings.Inside, if High <= Lines.Size (Source) and then
Going => Ada.Strings.Maps.Is In (Element =>
Ada.Strings.Forward, Lines.Get_Character (Source => Source,
From => From, Index => High),
To => Low) ; Set => Name_Character_Set) then
end case; -- From > 1 return 0;
when False => end if; -- High <= Lines.Size (Source) and...
From := Low; if Low > 1 and then
To := Low; Ada.Strings.Maps.Is_In (Element =>
end case; -- From <= Low +1 and Low < To Lines.Get Character (Source => Source,
end case; -- Going Index => Low -1),
end if; -- To > 0 Set => Name Character Set) then
end Find With First_ Character; return 0;
end if; -- Low > 1
end if; -- Low > O
procedure Find Name (Source : in Lines.Line; return Low;
From : out Positive; end Find Name;
To : out Natural;
Going : in Ada.Strings.Direction := end Segments.Sgml;
Ada.Strings.Forward) is




L es segments detype data : contenu textuel

with Ada.Characters.Latin 1;
with Ada.Text IO;
with Lines;

package Segments.Sgml.Data is
use Ada;
type Segment is new Segments.Sgml.Segment with private;

Unknown_Sgml_Entity exception;

function Create (Content in Lines.Line) return Segment;

procedure Write (Object
File
Text IO.Current_ Output) ;

in Segment;
in Text IO.File Type :=

procedure Write

(Object : in Segment;

Entities Resolved : in Boolean;

File : in Text IO.File Type := Text IO.Current Output) ;
function Get Level (Object in Segment) return Segments.Segment Level;
function Get Content (Object in Segment;

Entities Resolved in Boolean)

return Lines.Line;

procedure Set Content (Object in out Segment;
Value : in Lines.Line) ;
private
Ero constant String := String’ (1 => Ada.Characters.Latin_ 1.Ampersand) ;
-- SGML "opens a named entity reference"
Refc constant String := String’ (1 =>

Ada.Characters.Latin 1.Semicolon) ;
-- SGML "closes a reference"

type Segment is new Segments.Sgml.Segment with
record

Content

end record;

Lines.Line := Lines.Null Decid String;

procedure Set Segment (Object in out Segment;
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Content in Lines.Line) ;

end Segments.Sgml.Data;

with
with
with
with
with
with

Ada.IO_Exceptions;

Logs;

Parameters;

Read_File;

Sizes;

Table Of Strings And Static_Values_ G;

package body Segments.Sgml.Data is

package Entities is

new Table Of Strings And Static Values G (Character Type => Character,

String Type => String,
Less => "<",
Equals => "=",
Value Type =>

Lines.Line) ;

package Reader is new Read File

Entity Data Name

(Max_Field => Sizes.S Value,
Max Line Length => Lines.Decid Strings.Standard Max Size) ;

String :=
Parameters.Sgml _Entities Data File Name;

-- description of the format for entity data

- %
- %
- %

field separator is equal sign (=)

every data line has got at least 5 fields

only the second and the last field may be empty
(but they still have to exist).

-- 1lst field is the name of the SGML entity

-- 2nd field is the replacement string,
-- 3rd field is the ISO character set considered

which translates the entity
(capitalized)
cf. Iso_Set type

-- 4th to last but one field are Latin-1 codes

for characters of replacement string

-- last field is the current name to refer to the entity

Entity To Diacritic_Table
Entity To Diacritic Table Is Initialized

Entities.Table Type;
Boolean := False;

procedure Init Entities is

Duplicated Entries Boolean := False;
Last Natural;
Replacement Lines.Line;
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begin
if Entities.Is_Empty (Table => Entity To Diacritic_Table) then
Reader.Open (Name => Entity Data_Name) ;
Reader.Set Separators (To => "=");
while not Reader.End Of File loop
Reader.Fetch;
Last := Reader.Number Of Fields;
if Last > 1 then
Lines.Reset (Replacement) ;
for I in 4..Last-1 loop
Replacement :=
Lines.Append (Left => Replacement,
Right => Character’Val
(Reader.Field(I))) ;
end loop; -- for
Entities.Insert (Table => Entity To_Diacritic_Table,
Duplicate Item => Duplicated Entries,
Key => Reader.Field(1),
Value => Replacement) ;
if Duplicated Entries then
Logs.Write (Kind => Logs.Warning,
Localization =>
"Segments.Data_Sgml.Init Entities");
Logs.Write (Message => "The entity " & Reader.Field(1l) &
" is duplicated in file " &
Entity Data Name &
" ; (only the first translation is

considered) . ",
Ends_The Line => True);
end if;
end if;
end loop; -- while
Reader.Close;
Entity To_Diacritic_Table Is_Initialized := True;
end if;
exception

when Ada.IO Exceptions.Name Error =»>
Logs.Write (Kind => Logs.Error,
Localization =>
"procedure Segments.Data Sgml.Init Entities",
Exception Name => "Ada.IO Exceptions.Name Error",
Propagated => True) ;
Logs.Write (Message => "File " & Entity Data Name & "containing "

"data about SGML entities has not been found.",
Ends_The Line => True);
raise;
end Init Entities;

function Translate Entity (Name
begin

in String) return Lines.Line is
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case Name (1) = Ada.Characters.Latin_ 1.Number Sign is
when True =>
return Lines.To_Decid String
(String’ (1 =>
Character’Val (Integer’Value (Name
(2..Name’Last)))));
when False =>
return Entities.Value (Table => Entity To Diacritic_ Table,
Key => Name) ;
end case; -- Name (1) = Ada.Characters.Latin_ 1.Number Sign
exception
when Entities.Missing Item Error =>
case Entity To Diacritic_Table Is Initialized is
when True =>
Logs.Write (Kind => Logs.Warning,
Localization =>
"function
Segments.Data Sgml.Translate Entity",
Exception Name =>

"Segments.Data Sgml.Entities.Missing Item Error",
Propagated => True,
Propagation Name =>
"Segments.Data_Sgml.Unknown_ Sgml Entity");

Logs.Write (Message => "Entity &" & Name &
"; is not described in the entity data file " &
Entity Data Name &
" , it has not been translated.",
Ends_The Line => True);

raise Unknown Sgml_ Entity;

when False =>
Init_Entities;
return Translate Entity (Name => Name) ;
end case;
end Translate Entity;

function Translate Entities (Object in Lines.Line)
return Lines.Line

is
Not_Yet Read : Lines.Line := Object;
Result Lines.Line := Lines.Null Decid String;
Ero Position, Refc_Position, Cutting Position Natural;
begin
while not Lines.Is Empty (Not Yet Read) loop
Ero Position := Lines.Find String (Source => Not_ Yet Read,
Object => Ero,
Going => Ada.Strings.Forward) ;

exit when Ero_Position = 0;

Cutting Position := Ero Position-1;



Result :=
Lines.Append (Left => Result,
Right => Lines.Chunk (Source => Not_Yet Read,

From = 1,
To =>
Cutting Position)) ;
Lines.Delete (Source => Not_Yet Read,
From => 1,
To => Cutting Position);
Refc_Position := Lines.Find String (Source => Not_Yet Read,

Object => Refc,
Going => Ada.Strings.Forward) ;

exit when Refc Position = 0;

Cutting Position := Refc Position-1;
begin
Result :=
Lines.Append (Left => Result,
Right =>

Translate Entity (Lines.Get_String (Source =>
Not_Yet Read,

From =>
Ero’Length+1,
To =>
Cutting Position))) ;
Cutting Position := Cutting Position + Refc’Length;
exception
when Unknown Sgml Entity =>
Cutting Position := Cutting Position + Refc’Length;
Result :=

Lines.Append
(Left => Result,
Right => Lines.Chunk (Source => Not_ Yet Read,
From = 1,
To => Cutting Position));
end;

Lines.Delete (Source => Not_Yet Read,
From => 1,
To => Cutting Position);
end loop;
return Lines.Append (Left => Result, Right => Not Yet Read) ;
end Translate Entities;

function Get_Level (Object in Segment) return Segments.Segment Level

is
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begin
return Segments.Data;
end Get Level;

function Get Content (Object
Entities Resolved
return Lines.Line is

in Segment;
in Boolean)

begin
case Entities Resolved is
when True =>
return Translate Entities (Object.Content) ;
when False =>
return Object.Content;
end case; -- Entities Resolved
end Get Content;

procedure Set Content (Object in out Segment;
Value : in Lines.Line) is
begin
Object.Content := Value;
end Set Content;

procedure Set Segment (Object in out Segment;

Content : in Lines.Line) is
begin
Set_Segment (Object => Segments.Sgml.Segment (Object)) ;
Object.Content := Content;

end Set_Segment;

function Create (Content
Result Segment ;

begin
Set Segment (Object => Result, Content => Content) ;
return Result;

end Create;

in Lines.Line) return Segment is

procedure Write

(Object : in Segment;
Entities Resolved : in Boolean;
File : in Text IO.File Type := Text IO.Current Output)
is
begin

Ada.Text_IO.Put
(File => File,
Item => Lines.To_String (Get_Content
(Object => Object,
Entities Resolved =>

Entities Resolved))) ;

end Write;

procedure Write
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(Object : in Segment;

File : in Text IO.File Type := Text IO.Current Output) is
begin
Write (Object => Object,
Entities_Resolved => False,
File => File);

end Write;

end Segments.Sgml.Data;

Lessegmentsdetype méta: les balises

with Lines;
with Sgml Gis;

generic

type Tag Category is (<>);
with function To_Tag (Object : in Sgml_Gis.Generic_ Identifier)
return Tag Category is <>;

package Segments.Sgml.Meta G is

type Segment G is abstract new Segments.Sgml.Segment with private;

procedure Write (Tag : in Tag Category;
File : in Ada.Text_ IO.File Type :=
Ada.Text IO.Current Output) is abstract;

function Get_ Level (Object : in Segment_G)
return Segments.Segment Level;

function Is Start Tag (Object : in Segment G)
return Boolean is abstract;

function Get Tag (Object : in Segment_ G)
return Tag Category;

Empty Tag : Tag Category := To Tag (Sgml Gis.Null Gi) ;

function Is Empty Tag (Object : in Tag Category) return Boolean;

private

type Segment G is abstract new Segments.Sgml.Segment with
record
Gi : Sgml_Gis.Generic_Identifier := Sgml_Gis.Null Gi;
Tag : Tag_Category := Empty Tag;

end record;

procedure Set Segme

end Segments.Sgml.Meta

with Ada.Strings;

package body Segments.
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procedure Set Segment (Object : in out Segment G;

Content : in Lines.Line;

Index Gi End out Natural) ;
nt (Object : in out Segment G;

Tag : in Tag Category) ;
. G;
Sgml.Meta G is
ag (Object : in Tag Category) return Boolean is

function Is Empty T
begin

return Object =
end Is Empty Tag;

Empty Tag;

function Get_Level
begin

return Segments.
end;
function Get Tag (O
begin

return Object.Tal

end Get Tag;

procedure Set Segme

Index Gi_Beginni

(Object : in Segment G)
return Segments.Segment Level is

Meta;

bject : in Segment G)
return Tag Category is

gi

nt (Object : in out Segment G;
Content : in Lines.Line;

Index Gi_ End
ng : Positive;

out Natural) is

Tag Gi : Sgml Gis.Generic Identifier;

begin
Segments.Sgml.Fi

Tag Gi :=
Sgml_Gis.To_Gi

nd_Name (Source =>

Content,

From => Index Gi Beginning,

To => Index Gi_End,

Going => Ada.Strings.Forward) ;
Set Segment (Object => Segments.Sgml.Segment (Object)) ;

(Lines.Get_ String

(Source => Content,
From => Index Gi Beginning,
To => Index Gi_End));



Object.Gi := Tag Gi;
Object.Tag := To_Tag (Tag Gi);
end Set Segment;

procedure Set Segment (Object : in out Segment G;
Tag : in Tag Category) is

begin
Set_Segment (Object => Segments.Sgml.Segment (Object));
Object.Gi := Sgml Gis.To Gi (Tag_Category’Image (Tag));

Object.Tag := Tag;
end Set Segment;

end Segments.Sgml.Meta G;

Balises ouvrantes

with Ada.Text IO;
with Lines;

with Paths;

with Sgml Gis;

generic
package Segments.Sgml.Meta G.Stag G is

type Segment is new Segment G with private;

function Create (Content : in Lines.Line)
return Segment;

function Create (Tag : in Tag Category)
return Segment;

procedure Write (Object : in Segment;
File : in Ada.Text IO.File Type :=
Ada.Text_ IO.Current Output) ;
procedure Write (Tag : in Tag Category;
File : in Ada.Text IO.File Type :=
Ada.Text_ IO.Current Output) ;

function Is Start Tag (Object : in Segment) return Boolean;

procedure Get Attribute (Object : in Segment;

Name : in Sgml Gis.Generic_Identifier;

Value : out Lines.Line;
Is_Present : out Boolean) ;

procedure Get Attribute (Object : in Segment;

Name : in Sgml_Gis.Generic_Identifier;

Value : out Paths.Path;
Is Present : out Boolean) ;
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procedure Get Attribute (Object : in Segment;
Name : in String;
Value : out Lines.Line;
Is Present : out Boolean) ;

procedure Get Attribute (Object : in Segment;
Name : in String;
Value : out Paths.Path;
Is_Present : out Boolean) ;

procedure Set Attribute (Object : in out Segment;
Name : in Sgml Gis.Generic Identifier;
Value : in Lines.Line;
Add If Not Present : in Boolean) ;

procedure Set Attribute (Object : in out Segment;
Name : in Sgml Gis.Generic_Identifier;
Value : in Paths.Path;
Add_If Not Present : in Boolean) ;

private

type Segment is new Segment G with
record
Attributes : Lines.Line := Lines.Null Decid String;
end record;

procedure Set Segment (Object : in out Segment;
Content : in Lines.Line) ;

procedure Set Segment (Object : in out Segment;
Tag : in Tag Category) ;

end Segments.Sgml.Meta G.Stag G;

with Ada.Characters.Latin 1;
with Ada.Strings;

with Ada.Strings.Maps;

with Logs;

package body Segments.Sgml.Meta G.Stag G is

-- Attributes --
Vi : constant String :=

String’ (1=>Ada.Characters.Latin 1.Equals Sign) ;
-- SGML "value indicator"
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Lit : constant String :=
String’ (1=>Ada.Characters.Latin 1.Quotation) ;
-- SGML "literal delimiter"

Lita : constant String :=
String’ (1=>Ada.Characters.Latin 1.Apostrophe) ;
-- SGML "literal delimiter (alternative)"

procedure Find Attribute (Object : in Lines.Line;
Name : in Sgml_Gis.Generic_Identifier;
Name From : out Natural;
Value : out Lines.Line;
Value From : out Natural) is
-- Name_From = 0 indicates that the attribute has not been found
Field Beginning, Field End, Index, Index Alternate : Natural;

Index Translation : Natural := 0;

procedure Move_ Forward (To : in Natural) is

begin
Lines.Delete (Source => Value, From => 1, To => To);
Index Translation := Index Translation + To;

end Move Forward;

procedure Find Value (Literal Delimiter : in String) is
begin
if not Lines.Has_Characters (Object =>
Lines.Chunk (Source => Value,
From => 1,
To => Index -1),

In_Set =>
Segments.No_Sign Set) then
raise Syntax Error; -- signs between VI and LIT
end if;
Value From := Index Translation +

Index + Literal Delimiter’Length -1;
Move Forward (To => Value From - Index Translation);
Index := Lines.Find String (Source => Value,
Object => Literal Delimiter,
Going => Ada.Strings.Forward) ;

if Index = 0 then -- LIT is not closed
raise Syntax Error;

end if;

Value := Lines.Chunk (Source => Value,

From => 1, To => Index -1);
end Find Value;

begin
Value := Object;
loop
Field End := Lines.Find String ( Source => Value,
Object => Vi,
Going => Ada.Strings.Forward) ;
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if Field End = 0 then -- no more attributes
Name From := 0;
Value_ From := 0;
exit;

end if; -- Field end = 0

Field Beginning :=

Sgml_Gis.Find Gi (Source => Lines.Chunk (Source => Value,
From => 1,
To => Field End),
Object => Name,
Going => Ada.Strings.Backward) ;

if Field Beginning > 0 and then

Lines.Has Characters (Object =>
Lines.Chunk (Source => Value,
From =>
Field Beginning +
Sgml_Gis.Get_Size (Name),
To => Field End -1),
In Set => Segments.No Sign Set) then

-- no significant character between the attribute name and the value

-- either the attribute is present, or there is a SGML syntax error

Name From := Field Beginning + Index Translation;
Move_ Forward (To => Field End) ;
Field End := Lines.Find String ( Source => Value,

Object => Vi,
Going => Ada.Strings.Forward) ;
Index :=
Lines.Find String (Source => Value,
Object => Lit,
Going => Ada.Strings.Forward) ;
Index Alternate :=
Lines.Find String (Source => Value,
Object => Lita,
Going => Ada.Strings.Forward) ;
if 0 < Index and
(Index < Index Alternate or Index Alternate = 0) and
(Index < Field End or Field End = 0) then
Find Value (Literal Delimiter => Lit);
elsif 0 < Index Alternate and
(Index Alternate < Index or Index = 0) and
(Index_Alternate < Field End or Field End = 0) then

Index := Index Alternate;
Find Value (Literal Delimiter => Lita);
else -- Field End is the smallest > 0 (or all are null)
if Field End > 0 then
Value := Lines.Chunk (Source => Value,

From => 1, To => Field End -1);
Segments.Sgml.Find Name (Source => Value,
From => Field Beginning,
To => Field End,
Going => Ada.Strings.Backward) ;
case Field End > 0 is



when True =>
Value := Lines.Chunk (Source => Value,
From => 1,
To => Field Beginning -1);
when False =>
raise Syntax Error;
end case; -- Field End > 0
end if; -- Field End > 0
Segments.Sgml.Find Name (Source => Value,
From => Value From,
To => Field End,
Going => Ada.Strings.Forward) ;
Value := Lines.Chunk (Source => Value,
From => Value From,
To => Field End);

end if; -- Index / Index Alternate / Field End
exit;
else -- the attribute is not present in the field

Move Forward (To => Field End);
end if; -- Field Beginning > 0 and then Is_Subset...
end loop;
exception
when Syntax Error =>
Logs.Write (Kind => Logs.Warning,
Localization => "procedure
Segments.Sgml.Meta.Get Attr",
Exception Name => "Segments.Sgml.Meta.Syntax Error",
Propagated => False);
Logs.Write (Message => "The attribute " & Sgml Gis.Get Image
(Name) &
" may not be correctly delimited by a couple of " &
Lit & " or " & Lita & " in the tag :",
Ends_The Line => True);
Logs.Write (Data =>
Stago & Lines.To String (Object) & Tagc);
Name From := 0;
Value From := 0;
end Find Attribute;

function Is_Start Tag (Object
begin

return True;
end Is_Start_Tag;

in Segment) return Boolean is

procedure Get Attribute (Object in Segment;
Name : in Sgml_ Gis.Generic_Identifier;
Value out Lines.Line;
Is_Present out Boolean) is
Name Position, Value Position Natural;
begin
Find Attribute (Object => Object.Attributes,
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Name => Name,
Name From => Name Position,
Value => Value,
Value From => Value Position) ;
Is_Present := (Name_Position > 0);
end Get_ Attribute;

procedure Get Attribute (Object in Segment;
Name : in Sgml Gis.Generic Identifier;
Value out Paths.Path;
Is_Present : out Boolean) is
Path As A Line Lines.Line;
begin
Get_Attribute (Object => Object,
Name => Name,
Value => Path As A Line,
Is Present => Is Present);
case Is_Present is
when True =>
Value := Paths.To Decid String (Lines.To_String
(Path As A Line));
when False =>
Value := Paths.Null Decid String;
end case; -- Is_Present
end Get Attribute;

procedure Get Attribute (Object in Segment;
Name : in String;
Value out Lines.Line;
Is_Present out Boolean) is
begin
Get_Attribute (Object => Object,
Name => Sgml_Gis.To_Gi (Name),
Value => Value,
Is Present => Is Present);
end Get_ Attribute;

procedure Get Attribute (Object in Segment;
Name : in String;
Value out Paths.Path;
Is_Present : out Boolean) is
begin
Get Attribute (Object => Object,
Name => Sgml_Gis.To_Gi (Name),
Value => Value,
Is_Present => Is Present);
end Get Attribute;

procedure Set Attribute (Object in out Segment;
Name : in Sgml Gis.Generic_Identifier;
Value in Lines.Line;
Add_If Not Present in Boolean) is
Name Position, Value Position Natural;
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0ld_Value Lines.Line;
begin
Find Attribute (Object => Object.Attributes,
Name => Name,
Name From => Name_ Position,
Value => 0ld_Value,
Value From => Value Position) ;
case Name Position is
when 0 =>
if Add_If Not_ Present then
Object.Attributes :=
Lines.Append (Left => Object.Attributes,

Right => " " & Sgml Gis.Get Image (Name) &
"rEg V& " " & Lit &
Lines.To String (Value) & Lit);

end if; -- Add_If Not Present

when others =>
Object.Attributes :=
Lines.Replace (Source => Object.Attributes,
From => Value Position,
To => Value Position + Lines.Size (0ld Value)

By => Value);
end case; -- Name_ Position
end Set_Attribute;

procedure Set Attribute (Object in out Segment;
Name : in Sgml_ Gis.Generic_Identifier;
Value : in Paths.Path;
Add_If Not Present in Boolean) is
begin
Set_Attribute (Object => Object,
Name => Name,
Value => Lines.To Decid String
(Paths.To_String(Value)),
Add_If Not Present => Add _If Not Present) ;
end Set_Attribute;

procedure Set Segment (Object
Content

in out Segment;
in Lines.Line) 1is
Index : Natural;
begin
Set Segment (Object => Segment G (Object), Content => Content,
Index Gi_End => Index);
Object.Attributes := Lines.Delete (Source => Content,
From => 1,
To => Index) ;
if Index = 0 then
raise Segments.Sgml.Syntax Error;
end if; -- Index = 0
exception
when Segments.Sgml.Syntax Error =>
Logs.Write (Kind => Logs.Warning,
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Localization => "Segments.Sgml.Meta G.Stag",
Exception Name => "Segments.Sgml.Syntax Error",
Propagated => False);
Logs.Write (Message => "Empty open tag found : " &
"the tag is ignored.",
Ends_The Line => True);
end Set Segment;

procedure Set Segment (Object in out Segment;
Tag : in Tag Category) is
begin
Set_Segment (Object => Segment G (Object), Tag => Tag) ;
end Set Segment;

function Create (Content in Lines.Line)
return Segment is
Result : Segment;
begin
Set Segment (Object => Result, Content => Content) ;
return Result;
end Create;

function Create (Tag in Tag_Category)
return Segment is
Result : Segment;
begin
Set Segment (Object => Result, Tag => Tag);
return Result;
end Create;

procedure Write (Object in Segment;
File : in Ada.Text IO.File Type :=
Ada.Text IO.Current Output) is
begin
Ada.Text IO.Put (File => File,

Item => Segments.Sgml.Stago &
Tag Category’Image (Get Tag (Object)) &
Lines.To_String (Object.Attributes) &
Segments.Sgml.Tagc) ;

end Write;

procedure Write (Tag in Tag_Category;
File : in Ada.Text IO.File Type :=
Ada.Text IO.Current Output) is
begin
Ada.Text IO.Put (File => File,

Item => Segments.Sgml.Stago &
Tag Category’Image (Tag) &
Segments.Sgml.Tagc) ;

end Write;



end Segments.Sgml.Meta G.Stag G;

Balises fermantes

with Ada.Text IO;
with Lines;

generic
package Segments.Sgml.Meta G.Etag G is

type Segment is new Segment G with private;

function Create (Content in Lines.Line) return Segment;
function Create (Tag in Tag Category)
return Segment;

procedure Write (Object in Segment;
File : in Ada.Text IO.File Type :=
Ada.Text_ IO.Current Output) ;

procedure Write Short (Object in Segment;
File : in Ada.Text_ IO.File Type :=
Ada.Text_ IO.Current Output) ;

procedure Write (Tag in Tag_ Category;
File : in Ada.Text_ IO.File Type :=
Ada.Text_ IO.Current Output) ;

procedure Write Short (Tag in Tag_ Category;
File : in Ada.Text_ IO.File Type
Ada.Text_ IO.Current Output) ;

function Is_Start Tag (Object in Segment)
return Boolean;

private
type Segment is new Segment G with null record;

procedure Set Segment (Object
Content

in out Segment;
in Lines.Line) ;

procedure Set_ Segment (Object in out Segment;
Tag : in Tag Category) ;

end Segments.Sgml.Meta G.Etag G;
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package body Segments.Sgml.Meta G.Etag G is

function Is_Start Tag (Object in Segment)
return Boolean is
begin
return False;
end Is_Start Tag;

procedure Set Segment (Object
Content

in out Segment;
in Lines.Line) is
Index Natural;
begin
Set_Segment (Object => Segment G (Object), Content => Content,
Index Gi_End => Index);

end Set_Segment;

procedure Set Segment (Object in out Segment;
Tag : in Tag Category) is
begin
Set Segment (Object => Segment G (Object), Tag => Tag) ;
end Set_Segment;
function Create (Content in Lines.Line) return Segment is
Result Segment ;
begin
Set Segment (Object => Result, Content => Content) ;
return Result;
end Create;

function Create (Tag in Tag_Category)
return Segment is
Result Segment ;
begin
Set Segment (Object => Result, Tag => Tag);
return Result;
end Create;

procedure Write (Object in Segment;
File : in Ada.Text IO.File Type :=
Ada.Text IO.Current Output) is
begin
Ada.Text IO.Put Line (File => File,
Item => Segments.Sgml.Etago &
Tag Category’Image (Get Tag (Object)) &
Segments.Sgml.Tagc) ;
end Write;

procedure Write (Tag in Tag_ Category;
File : in Ada.Text IO.File Type :=
Ada.Text IO.Current Output) is
begin
Ada.Text IO.Put Line (File => File,
Item => Segments.Sgml.Etago &
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Tag_Category’Image (Tag) &
Segments.Sgml.Tagc) ;
end Write;

procedure Write Short (Object in Segment;
File : in Ada.Text IO.File Type :=
Ada.Text_ IO.Current Output) is
begin
Ada.Text IO.Put (File => File,

Item => Segments.Sgml.Etago &
Tag_Category’Image (Get Tag (Object)) &
Segments.Sgml.Tagc) ;

end Write Short;

procedure Write Short (Tag in Tag Category;
File : in Ada.Text IO.File Type :=
Ada.Text_ IO.Current Output) is
begin
Ada.Text IO.Put (File => File,

Item => Segments.Sgml.Etago &
Tag_Category’Image (Tag) &
Segments.Sgml.Tagc) ;

end Write Short;

end Segments.Sgml.Meta G.Etag G;

Segments de type indéfini (data ou méta)

with Ada.Text IO;

with Lines;

with Polymorphic Objects G;

with Segments.Sgml.Data;

with Segments.Sgml.Meta G;

with Segments.Sgml.Meta G.Stag G;
with Segments.Sgml.Meta G.Etag G;
with Sizes;

generic
with package Meta is new Segments.Sgml.Meta G (<>);
with package Stag is new Meta.Stag G (<>);
with package Etag is new Meta.Etag G (<>);

package Segments.Sgml.Mixed G is

use Ada;

package Data renames Segments.Sgml.Data;
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package Polymorphic Objects is
new Polymorphic Objects G (Object Root => Segments.Sgml.Segment) ;

subtype Segment is Polymorphic Objects.Polymorphic_Object;

-- function To_ Segment (Object in Data.Segment)
- return Segment;
function To_Segment is
new Polymorphic Objects.To Polymorphic G (Object Child =»>
Data.Segment) ;

-- function To_ Segment (Object in Stag.Segment)
- return Segment;
function To_Segment is
new Polymorphic Objects.To Polymorphic G (Object Child =>
Stag.Segment) ;

-- function To_ Segment (Object in Etag.Segment)
- return Segment;
function To_Segment is
new Polymorphic Objects.To Polymorphic G (Object Child =»>
Etag.Segment) ;

-- function To Data (Object
function To Data is
new Polymorphic Objects.To Child G (Object_ Child => Data.Segment) ;

in Segment) return Data.Segment;

-- function To_Stag (Object in Segment)
-- return Stag.Segment;
function To_Stag is
new Polymorphic Objects.To Child G (Object Child => Stag.Segment) ;

-- function To Etag (Object in Segment)
-- return Etag.Segment;
function To Etag is
new Polymorphic Objects.To Child G (Object_ Child => Etag.Segment) ;

function Get_ Level (Object in Segment)
return Segments.Segment Level;
function Is Start Tag (Object in Segment) return Boolean;

procedure Write Short

(Tag : in Meta.Tag Category;

Text : in Lines.Line;

Ends_The Unit : in Boolean;

File : in Text IO.File Type := Text IO.Current Output);

function Stag To Etag (Object in Stag.Segment)
return Etag.Segment;



generic
with procedure Action Data (Object in Data.Segment) ;
with procedure Action Stag (Object : in Stag.Segment) ;
with procedure Action Etag (Object : in Etag.Segment) ;
procedure Action G (Object in Segment) ;

-- Better, if Action Data, Action Stag and Action Etag have the same name,
-- one can define Action (Object in Segment) like Get_Level in this
package.

generic
with procedure Action (Object
procedure For Each Segment G (File

in Segment) ;
in out Ada.Text IO.File Type);

with Ada.Characters.Latin 1;
with Logs;

package body Segments.Sgml.Mixed G is

function Get Level (Object in Segment)
return Segments.Segment Level is
use Data;
use Stag;
use Etag;
begin
return Get Level (Polymorphic Objects.Get Details (Object) .all);
exception
when Constraint_ Error =>
pragma Debug (Logs.Write (Kind => Logs.Trace,
Localization => "instance of " &
"Segments.Sgml.Mixed G.Get_ Level",
Exception Name =>
"Constraint_ Error",
Propagated => True,
Propagation Name =>
"Polymorphic Objects.Type Error")) ;
raise Polymorphic_ Objects.Type Error;
end Get Level;
function Is_ Start Tag (Object in Segment) return Boolean is
use Meta;
use Stag;
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use Etag;
begin
return Is Start Tag (Meta.Segment G’Class
(Polymorphic_Objects.Get Details (Object) .all));
exception
when Constraint Error =>
pragma Debug (Logs.Write (Kind => Logs.Trace,
Localization => "instance of " &
"Segments.Sgml.Mixed G.Is Start Tag",
Exception Name =>
"Constraint Error",
Propagated => True,
Propagation Name =>
"Polymorphic_Objects.Type Error")) ;
raise Polymorphic Objects.Type Error;
end Is_Start Tag;

procedure Read (Current Segment out Segment;
File : in Ada.Text IO.File Type :=
Ada.Text_ IO.Current_ Input;
Buffer in out Lines.Line;
Next Beginning Seen in out Boolean;
Next Is Stag in out Boolean;
No More Segments out Boolean) is

Cutting Position, Cutting Length Natural;
Current_Content Lines.Line := Lines.Null Decid String;
Current Level Segments.Segment Level;

function Get Input With Success return Boolean is
begin
case Lines.Is Empty (Buffer) is
when True =>
loop
case Ada.Text IO.End Of File (File) is
when True =>
No More Segments := True;
exit;
when False =>
Lines.Read (Object => Buffer, File => File);
Segments.Clean_ Input (Buffer);
exit when not Lines.Is Empty (Buffer);

end case; -- ...End Of File (File)
end loop;
return No More Segments = False;

when False =>
return True;
end case; -- Lines.Is Empty (Buffer)
end Get_ Input With Success;
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procedure Find Opening is
Stago_Position, Etago_ Position : Natural;
begin
Stago_Position :=
Lines.Find String (Source => Buffer,
Object => Stago,
Going => Ada.Strings.Forward) ;
Etago_Position :=
Lines.Find String (Source => Buffer,
Object => Etago,
Going => Ada.Strings.Forward) ;
case Stago Position = 0 is
when True =>
case Etago Position = 0 is
when True =>

Cutting Position := 0;
when False =>
Cutting Position := Etago Position;
Next Is Stag := False;
Cutting Length := Etago’Length;
Next Beginning Seen := True;
end case; -- Etago Position = 0
when False =>
Next Beginning Seen := True;
case (Stago_Position < Etago_Position or
Etago_Position = 0) is
when True =>
Cutting Position := Stago Position;
Next_ Is_ Stag := True;
Cutting Length := Stago’Length;
when False =>
Cutting Position := Etago Position;
Next Is Stag := False;
Cutting Length := Etago’Length;
end case; -- Stago Position < Etago_Position
-- or Etago Position = 0
end case; -- Stago_ Position = 0

end Find Opening;

procedure Find Closing is
begin
Cutting Position :=
Lines.Find String (Source => Buffer,
Object => Tagc,
Going => Ada.Strings.Forward) ;
Cutting Length := Tagc’Length;
end Find Closing;

procedure Transfer Input is
begin
Current Content := Lines.Append (Left => Current Content,
Right => Buffer);
Current Content := Lines.Append (Left => Current Content,
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Right =>
Lines.To Decid String (String’ (1 =>
Ada.Characters.Latin 1.Space))) ;
Lines.Reset (Buffer);
end Transfer Input;

procedure Split Input is
begin
Cutting Position := Cutting Position -1;
Current_ Content :=
Lines.Append (Left => Current Content,
Right =>
Lines.Chunk (Source => Buffer,
From => 1,
To => Cutting Position)) ;
Buffer :=
Lines.Delete (Source => Buffer,
From => 1,
To => Cutting Position + Cutting Length) ;
end Split Input;

procedure Return_ Segment (Level : in Segments.Segment Level) is
begin
case Level is
when Segments.Data =>
Segments.Clean Input (Current Content) ;
case Segments.Is Significant (Current Content) is
when True =>
Current Segment :=
To_Segment (Data.Create (Content =>
Current Content)) ;
when False =>
Read (Current Segment => Current Segment,
File => File,
Buffer => Buffer,
Next Beginning Seen => Next Beginning Seen,
Next Is Stag => Next Is Stag,
No More Segments => No_More Segments) ;
end case; -- Segments.Is Significant (Current Content)
when Segments.Meta =>
case Next Is Stag is
when True =>
Segments.Clean Input (Current Content) ;
case Segments.Is Significant (Current Content) is
when True =>
Current_ Segment :=
To Segment (Stag.Create (Content =>
Current_Content)) ;
when False =>
Read (Current_ Segment => Current_ Segment,
File => File,
Buffer => Buffer,
Next Beginning Seen =>



Next Beginning Seen,
Next Is_Stag => Next Is Stag,

No More_Segments => No_ More_Segments) ;

end case; -- Segments.Is_Significant

(Current_Content)
when False =>
Current_Segment :=
To_Segment (Etag.Create (Content =>
Current Content)) ;
end case; -- Next Is Stag
end case; -- Level
end Return Segment;

begin
No_More_ Segments := False;

case Next Beginning Seen is
when True =>
Current_Level := Segments.Meta;
Next Beginning Seen := False;
when False =>
if Get_Input With Success then
Find Opening;
case Cutting Position = 1 is
when True =>
Current Level := Segments.Meta;
Buffer := Lines.Delete (Source => Buffer,
From => 1,
To => Cutting Length);
Next Beginning Seen := False;
when False =>
Current Level := Segments.Data;
end case; -- Cutting Position
end if; -- Get_Input With Success
end case; -- Next Beginning Seen

if not No_More Segments then
case Current_Level is
when Segments.Data =>
loop
case Cutting Position = 0 is
when True =>
Transfer_ Input;
when False =>
Split_Input;
Return Segment (Level => Segments.Data) ;
exit;
end case; -- Cutting Position = 0
if not Get_ Input With Success then
Return Segment (Level => Segments.Data) ;
exit;
end if; -- not Get_ Input With Success
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Find Opening;
end loop;
when Segments.Meta =>
loop
case Get Input With Success is
when True =>
Find Closing;
case Cutting Position is
when 0 =>
Transfer Input;
when others =>
Split_Input;
Return Segment (Level => Segments.Meta) ;
exit;
end case; -- Cutting Position
when False =>
raise Segments.Sgml.Syntax Error;

end case; -- Get_Input With Success
end loop;
end case; -- Current Level
end if; -- not No More Segments

exception
when Segments.Sgml.Syntax Error =>

Logs.Write (Kind => Logs.Echo,
Localization => "instance of " &
"Segments.Sgml.Mixed G.Read",
Exception Name =>
"Segments.Sgml.Syntax Error",
Propagated => False);
Logs.Write (Message =>
"Unclosed tag : no more data in the file" &
" to find a Tagc (>).",
Ends_The Line => True);
Return Segment (Level => Segments.Meta) ;

end Read;

-- generic

begin

with procedure Action Data
with procedure Action_ Stag
with procedure Action Etag
procedure Action G (Object : in

Object : in Data.Segment) ;
Object : in Stag.Segment) ;
Object : in Etag.Segment) ;
egment) is

0~ —~ —~

case Get_Level (Object) is

when Segments.Data =>
Action Data (To_Data (Object));
when Segments.Meta =>
case Is_Start Tag (Object) is
when True =>
Action_ Stag (To_Stag (Object));
when False =>

Programme d’interprétation de fichiers et de traduction dansla DTD Corpus



660

Action_Etag (To_Etag (Object));
end case; -- Is_Start Tag (Object)
end case; -- Get Level (Object)
end Action G;

-- generic
-- with procedure Action (Object
procedure For Each Segment G (File

in Segment) ;
in out Ada.Text IO.File Type) is

Current_Segment Segment ;
Buffer Lines.Line := Lines.Null Decid String;
Next Beginning Seen, Next Is Stag, No_More Segments Boolean :=
False;
begin
Ada.Text IO.Reset (File => File, Mode => Ada.Text IO.In File);

loop
Read (Current_Segment => Current_ Segment,
File => File,
Buffer => Buffer,
Next Beginning Seen => Next Beginning_ Seen,
Next Is_Stag => Next Is Stag,
No More_Segments => No_ More_Segments) ;
exit when No More_ Segments;
Action (Current Segment) ;
end loop;

end For_ Each Segment G;

procedure Write Short (Tag in Meta.Tag_Category;
Text : in Lines.Line;
Ends_The Unit in Boolean;
File : in Ada.Text_ IO.File Type :=
Ada.Text IO.Current Output) is
begin
Stag.Write (Object => Stag.Create (Tag => Tag), File => File);
Data.Write (Object => Data.Create (Content => Text), File => File);
case Ends_The Unit is
when True =>
Etag.Write Short (Object => Etag.Create (Tag => Tag),
File => File);
when False =>
Etag.Write Short (Object => Etag.Create (Tag => Tag),
File => File);
end case; -- Ends_The Unit
end Write_ Short;

function Stag To Etag (Object in Stag.Segment)
return Etag.Segment is
begin
return Etag.Create (Tag => Stag.Get Tag (Object));
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end Stag To Etag;

end Segments.Sgml.Mixed G;

L e contexte (emboitement des éléments ouverts)

with Segments.Sgml.Meta G;

with Segments.Sgml.Meta G.Etag G;
with Segments.Sgml.Meta G.Stag G;
with Sizes;

generic
with package Meta is new Segments.Sgml.Meta G (<>);
with package Stag is new Meta.Stag G (<>);
with package Etag is new Meta.Etag G (<>);
Default Base in Meta.Tag Category;
with function Is Base Level (Object in Meta.Tag Category)
return Boolean
is <>; -- generally last level before DATA ; may be omitted
with function Is Infra Level (Object in Meta.Tag Category)
return Boolean
is <>;
-- content of base level, mixed with DATA

with function Is_Transparent (Object in Meta.Tag Category)
return Boolean
is <>;

with function Can Contain (Outside, Inside
return Boolean

in Meta.Tag Category)

is <>;

with procedure Find Implicit Tag (From : in Meta.Tag Category;
Next : out Meta.Tag Category;
Towards : in Meta.Tag Category;
Base : in Meta.Tag Category;
No_ More : out Boolean)

is <>;

with procedure Find Implicit Tag (Next : out Meta.Tag Category;
Towards : in Meta.Tag Category;
Base : in Meta.Tag Category;
No_ More : out Boolean)

is <>;

package Segments.Sgml.Contexts G is

type Tag_Context is private;



Empty Context : exception;
Out_Of Bound Index : exception;

function Get_ Present Context (Object : in Tag Context)
return Meta.Tag Category;

function Test Present Context (Object : in Tag Context;
Value : in Meta.Tag Category)
return Boolean;

function Get Base (Object : in Tag Context)
return Meta.Tag Category;

procedure Set Base (Object : in out Tag Context;
Value : in Meta.Tag Category) ;

procedure Reset Base (Object : in out Tag Context) ;
procedure Write (Object : in Tag Context;

File : in Ada.Text IO.File Type :=

Ada.Text_ IO.Current Output) ;
private
Depth Max : constant Positive := Sizes.M Value;
subtype Depth is Positive range 1..Depth Max;
subtype Depth Index is Natural range 0..Depth Max;
type Tag Memory is array (Depth) of Stag.Segment;
type Tag Feature is array (Depth) of Boolean;
type Tag Context is
record

Tag : Tag Memory;
Is_Explicit : Tag Feature;

Base : Meta.Tag Category := Default Base;
To Open : Depth Index := 0;

To_Close : Depth Index := 0;

Index Bound : Depth Index := 0;

end record;
function Get Segment (Object : in Tag Context;
Index : in Depth Index)
return Stag.Segment;
function Get Tag (Object : in Tag Context;
Index : in Depth Index)
return Meta.Tag Category;

function Get_ To Open_ Segment (Object : in Tag Context)
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return Stag.Segment;

function Get To Close Segment (Object : in Tag Context)
return Stag.Segment;

function Get To Open Tag (Object : in Tag Context)
return Meta.Tag Category;

function Get_To Close_Tag (Object : in Tag Context)
return Meta.Tag Category;

function Has No Virtual (Object : in Tag Context) return Boolean;

function Segment To Open Is Explicit (Object : in Tag_ Context)
return Boolean;

end Segments.Sgml.Contexts G;

with Logs;

package body Segments.Sgml.Contexts G is

function Get Base (Object : in Tag_ Context)
return Meta.Tag Category is
begin
return Object.Base;
end Get_ Base;

procedure Set Base (Object : in out Tag Context;
Value : in Meta.Tag_Category) is
begin
Object.Base := Value;

end Set Base;

procedure Reset Base (Object : in out Tag_Context) is
begin

Set_Base (Object => Object, Value => Default Base);
end Reset Base;

function Get Segment (Object : in Tag Context;
Index : in Depth Index)
return Stag.Segment is
begin
return Object.Tag (Index);
exception
when Constraint Error =>
case Index = 0 is
when True =>
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Logs.Write (Kind => Logs.Error,
Localization =>
"Segments.Sgml.Context_ G.Get_Segment",
Exception Name => "Constraint Error",
Propagated => True,
Propagation Name =>
"Segments.Sgml.Context G.Empty Context") ;
Logs.Write (Message => "Seeking for Segment whereas " &
"context is empty.",
Ends_The Line => True);
raise Empty Context;
when False =>
pragma Debug (Logs.Write (Kind => Logs.Trace,
Localization =>

"Segments.Sgml.Context G.Get_Segment",
Exception Name =>
"Constraint_ Error",
Propagated => True,
Propagation Name =>

"Segments.Sgml.Context G.Out_Of Bound Index")) ;
raise Out_Of Bound Index;
end case; -- Index
end Get Segment;

function Get Tag (Object in Tag Context;
Index in Depth Index)
return Meta.Tag Category is
begin
return Stag.Get Tag (Get Segment (Object => Object, Index => Index));
exception
when others =>
Logs.Write (Kind => Logs.Echo,
Localization =>
"Segments.Sgml.Context G.Get_Tag") ;
raise;
end Get_Tag;

function Get To_Open_ Segment (Object in Tag_Context)
return Stag.Segment is
begin
return Get Segment (Object => Object, Index => Object.To Open) ;
exception
when others =>
Logs.Write (Kind => Logs.Echo,
Localization =>
"Segments.Sgml.Context G.Get_To Open_Segment") ;
raise;
end Get_To_Open_Segment;

function Get_ To_Close_Segment (Object in Tag_Context)
return Stag.Segment is

ANNEXE V.3
begin
return Get_Segment (Object => Object, Index => Object.To_Close) ;
exception

when others =>
Logs.Write (Kind => Logs.Echo,
Localization =>
"Segments.Sgml.Context G.Get To Close Segment") ;
raise;
end Get To Close Segment;

function Get To Open Tag (Object in Tag Context)
return Meta.Tag_Category is
begin
return Get_ Tag (Object => Object, Index => Object.To_Open) ;
exception
when others =>
Logs.Write (Kind => Logs.Echo,
Localization =>
"Segments.Sgml.Context G.Get To Open Tag") ;
raise;
end Get To Open Tag;

function Get To Close Tag (Object in Tag_ Context)
return Meta.Tag_Category is
begin
return Get_Tag (Object => Object, Index => Object.To_Close) ;
exception
when others =>
Logs.Write (Kind => Logs.Echo,
Localization =>
"Segments.Sgml.Context G.Get To Close Tag");
raise;
end Get To Close Tag;

function Has_No Virtual (Object : in Tag Context) return Boolean is
begin

return Object.To Open = Object.To Close;
end Has_No_Virtual;

function Segment To Open Is Explicit (Object in Tag_Context)
return Boolean is
begin
return Object.Is Explicit (Object.To Open) ;
exception
when Constraint Error =>
case Object.To Open = 0 is
when True =>
Logs.Write (Kind => Logs.Error,
Localization =>

"Segments.Sgml.Context G.Segment To Open Is Explicit",
Exception Name => "Constraint Error",
Propagated => True,



Propagation Name =>
"Segments.Sgml.Context G.Empty Context") ;

Logs.Write (Message => "Seeking for Segment feature " &
"whereas context is empty.",
Ends_The Line => True);

raise Empty Context;

when False =>
pragma Debug (Logs.Write (Kind => Logs.Trace,
Localization =>

"Segments.Sgml.Context G.Segment To_Open Is Explicit",
Exception Name =>
"Constraint Error",
Propagated => True,
Propagation Name =>

"Segments.Sgml.Context G.Out_Of Bound Index")) ;
raise Out_Of Bound Index;
end case; -- Object.To Open = 0
end Segment To_Open Is Explicit;

function Get Present Context (Object in Tag_Context)
return Meta.Tag Category is
begin
return Get To Open Tag (Object) ;
end Get_ Present Context;

function Test Present_ Context (Object in Tag_Context;
Value in Meta.Tag Category)
return Boolean is
function "=" (Left, Right in Meta.Tag Category)
return Boolean

renames Meta."=";

begin
return (Object.To Open > 0 and then Get To_Open Tag (Object) =
Value) ;
end Test Present_ Context;

procedure Write (Object in Tag_ Context;
File : in Ada.Text_ IO.File Type :=
Ada.Text IO.Current Output) is
begin
Ada.Text IO.Put (Item => "**x*kxu,
for I in 1..0bject.To Open loop
Ada.Text IO.Put (Item => Stago &
Meta.Tag Category’Image
(Stag.Get_Tag (Object.Tag (I))) &
Tagc,

File => File);
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File => File);
end loop; -- I in 1..0Object.To Open
Ada.Text IO.Put (Item => "******x To Close = " &
Integer’Image (Object.To_Close),
File => File);
Ada.Text IO.New_Line (File => File);
end Write;

end Segments.Sgml.Contexts G;

L estraitements contextuels

with Lines;
with Segments.Sgml.Data;

generic
with procedure Action On Virtual Opening (Object : in Stag.Segment) ;
with procedure Action On Real Opening (Object : in Stag.Segment) ;
( )
)

7

with procedure Action On Virtual Closing (Object : in Stag.Segment
with procedure Action On Real Closing (Object : in Stag.Segment
-- actions are done after the change of the context,
-- because the state of the context should not be modified
-- during the operation of opening/closing

7

with procedure Action On Data (Object in Segments.Sgml.Data.Segment) ;
package Segments.Sgml.Contexts G.Process G is

package Data renames Segments.Sgml.Data;

type Tag Context Access is access all Tag Context;

procedure Init Context (Object in Tag Context Access) ;

procedure Opening (Object
Maybe Done

in Stag.Segment;
in Boolean := False);

procedure Opening (Object
Maybe Done

in Meta.Tag Category;
in Boolean := False);
procedure Actualize (Object in Data.Segment) ;

procedure Actualize (Object in Lines.Line);

procedure Closing (Object : in Meta.Segment G’Class;
Maybe Done : in Boolean := False);

procedure Closing (Object : in Meta.Tag_Category;
Maybe Done : in Boolean := False);
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procedure Closing If Last (Object in Meta.Tag Category) ;
procedure Closing Base If Not_ Done;

end Segments.Sgml.Contexts G.Process_G;

with Logs;

package body Segments.Sgml.Contexts G.Process G is

Context Tag_Context Access;
procedure Init Context (Object
begin

Context := Object;
end Init Context;

in Tag Context Access) is

function "=" (Left, Right : in Meta.Tag Category)
return Boolean
renames Meta."=";

function "=" (Left, Right : in Stag.Segment)
return Boolean

renames Stag."=";

procedure Closing (Object : in Meta.Tag Category;

Maybe Done in Boolean := False) is
procedure Processing is
Stag_Object Stag.Segment := Get_ To Open_ Segment (Context.all);

begin
if Is Base_ Level (Object) then
Reset Base (Context.all);
end if; -- Is_Base Level (Object)
case Has No Virtual (Context.all) is
when True =>
Context.all.To_Open := Context.all.To Open -1;
Context.all.To_Close := Context.all.To Open;
Action On_Real Closing (Object => Stag Object) ;
when False =>

Context.all.To_Open := Context.all.To Open -1;
Action On_Virtual Closing (Object => Stag Object);
end case; -- Has_No Virtual (Context.all)

end Processing;

begin
if not (Is_ Transparent (Object) or
(Maybe Done and
(Context.all.To Open < Context.all.Index Bound and then
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Get Tag (Object => Context.all,
Index => Context.all.To Open +1) = Object)))
case Meta.Is Empty Tag (Object) is
when True =>
loop
case Context.all.To Open = 0 is
when True =>
raise Segments.Sgml.Syntax Error;
when False =>
case Segment To Open Is Explicit (Context.all)
when True =>

Processing;
exit;
when False =>
Processing;
end case; -- Segment To Open Is Explicit
(Context.all)
end case; -- Context.all.To Open = 0
end loop;
when False =>
loop

case Context.all.To Open = 0 is
when True =>
raise Segments.Sgml.Syntax Error;
when False =>
case Get_To_Open Tag (Context.all) = Object is
when True =>
Processing;
exit;
when False =>
case Can Contain (Outside => Object,
Inside =>
Get To Open Tag

(Context.all)) is
when True =>
Processing;
when False =>
raise Segments.Sgml.Syntax Error;
end case; -- Can_Contain...
end case; -- Get_To Open Tag (Context.all) =
Object
end case; -- Context.all.To Open = 0
end loop;
end case; -- Meta.Is_Empty Tag (Object)
end if; -- not (Is Transparent (...) or (Maybe Done and...
exception

when Segments.Sgml.Syntax Error =>
Logs.Write (Kind => Logs.Warning,
Localization =>
"Segments.Sgml.Context G.Process_G.Closing",
Exception Name => "Segments.Sgml.Syntax Error",
Propagated => False);
Logs.Write (Message => "Try to close a tag whereas " &

then

is



"there is no matching start tag.",
Ends_The Line => True);
end Closing;

procedure Closing (Object in Meta.Segment G’Class;
Maybe Done in Boolean := False) is
use Meta;
use Stag;
use Etag;
begin
Closing (Object => Get Tag (Object),
Maybe Done => Maybe Done) ;
end Closing;

procedure Closing If Last (Object
begin

in Meta.Tag Category) is

if Test_ Present Context (Object => Context.all, Value => Object) then
Closing (Object => Object, Maybe Done => False);
end if;
end Closing If Last;
procedure Closing Base If Not Done is
Checked Tag Meta.Tag Category;
begin
while Context.all.To Open > 0 loop
Checked Tag := Get_To Open Tag (Context.all);
case Is_Infra Level (Checked Tag) is
when True =>
Closing (Object => Checked Tag, Maybe Done => False);
when False =>
if Is Base_ Level (Checked Tag) then
Closing (Object => Checked Tag, Maybe Done => False);
end if; -- Is_Base Level (Checked Tag)
exit;
end case; -- Is_Infra Level (Checked Tag)
end loop; -- Context.all.To Open > 0
end Closing Base_ If Not_ Done;
procedure Opening (Object in Stag.Segment;
Maybe Done in Boolean := False) is
Object_ Tag Meta.Tag Category := Stag.Get Tag (Object);
Checked_Tag, Next Tag Meta.Tag_Category;
Current Base Meta.Tag Category := Get Base (Context.all);

Is_Last_ Processing Boolean;

procedure Processing (Current Object : in Stag.Segment;
Current Tag : in Meta.Tag Category;
Is_Explicit : in Boolean) is

begin
if Is Base Level (Current Tag) then
Set Base (Object => Context.all, Value => Current Tag) ;
end if; -- Is_Base Level (Current Tag)
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Context.all.To Open := Context.all.To Open +1;
if Context.all.To Open > Context.all.Index Bound then
Context.all.Index Bound := Context.all.To Open;

end if; -- Context.all.To_Open > Context.all.Index Bound
Context.all.Tag (Context.all.To Open) := Current Object;
Context.all.Is Explicit (Context.all.To_Open) := Is_Explicit;
Action On Virtual Opening (Object => Current Object);

end Processing;

begin

if not (Meta.Is Empty Tag (Object Tag) or
Is_Transparent (Object Tag) or
(Maybe Done and
(not Has_No Virtual (Context.all) and then
Get To Open Segment (Context.all) = Object))) then
loop -- closing loop
if Context.all.To Open = 0 then

Find Implicit Tag (Next => Next_ Tag,
Towards => Object Tag,
Base => Current_ Base,
No More => Is Last Processing) ;
exit;
end if; -- Context.all.To Open = 0
Checked Tag := Get_To Open Tag (Context.all);

case Can Contain (Outside => Checked Tag,
Inside => Object Tag) is
when True =>

Find Implicit Tag (From => Checked Tag,
Next => Next Tag,
Towards => Object Tag,
Base => Current Base,

No More => Is_Last Processing) ;
exit;
when False =>
Closing (Object => Checked Tag, Maybe Done => False);

Current Base := Get_ Base (Context.all);
end case; -- Can_Contain...
end loop; -- closing loop
while not Is Last Processing loop -- opening loop
Processing (Current Object => Stag.Create (Next Tag),
Current_Tag => Next_ Tag,
Is_Explicit => False) ;
Checked Tag := Next Tag;
Find Implicit Tag (From => Checked Tag,
Next => Next Tag,
Towards => Object Tag,
Base => Current Base,
No More => Is_Last Processing) ;
end loop; -- opening loop
Processing (Current Object => Object,
Current Tag => Object Tag,
Is_Explicit => True) ;
end if; -- ((not Meta.Is Empty Tag (...)) or
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-- (not Is_Transparent (...)) or
-- (not (Maybe Done and...
end Opening;

procedure Opening (Object : in Meta.Tag Category;
Maybe Done : in Boolean := False) is
begin
Opening (Object => Stag.Create (Tag => Object),
Maybe Done => Maybe_ Done) ;
end Opening;

procedure Actualize (Object : in Data.Segment) is
begin
case Context.all.To Open > 0 is
when True =>
declare
Checked Tag : Meta.Tag Category :=
Get_To_Open Tag (Context.all);
begin
if not (Is_Base_ Level (Checked Tag) or
Is_Infra Level (Checked Tag)) then
Opening (Object => Context.all.Base, Maybe Done =>

False) ;
end if; -- not (Is_Base Level... or Is_Infra Level...)
end;
when False =>
Opening (Object => Context.all.Base, Maybe Done => False);
end case; -- Context.all.To Open > 0
while not Has_No Virtual (Context.all) loop
Context.all.To_Close := Context.all.To Close +1;
Action On_Real Opening (Get_ To_Close_Segment (Context.all));
end loop; -- while not Has No_Virtual (Context.all)

Action On_Data (Object);
end Actualize;

procedure Actualize (Object : in Lines.Line) is
begin

Actualize (Data.Create (Content => Object)) ;
end Actualize;

end Segments.Sgml.Contexts G.Process_G;

d) Uneinstance de segments SGML : les segments
HTML

Définition du jeu de balises et de son comportement

with Sgml Gis;
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package Segments.Sgml.Html is

type Tag is (Html, Header Side, Title, Base Url, Body_ Side,
Heading, High Division, Low Division, Dividing, Caesura,
List, Item, Definiendum, Definiens,
Table, Caption, Row, Header Cell, Data Cell,
Alt _Media, Code, Other, Null Tag);

function To_Tag (Object : in Sgml_Gis.Generic Identifier) return Tag;
Root_Tag : constant Tag := Html;

Default Base : constant Tag := Low_Division;

function Is_Transparent (Object : in Tag) return Boolean;

-- Transparent means that Object should not be recorded in Tag Context

function Is Base Level (Object : in Tag) return Boolean;
-- used for setting Base in Tag Context

function Is_Infra Level (Object : in Tag) return Boolean;
function Can_Contain (Outside, Inside : in Tag) return Boolean;
procedure Find Implicit Tag (From : in Tag;

Next : out Tag;

Towards : in Tag;

Base : in Tag;

No_ More : out Boolean) ;

-- using Find Implicit Tag supposes that Can Contain (From, Towards)

procedure Find Implicit Tag (Next : out Tag;
Towards : in Tag;
Base : in Tag;
No_ More : out Boolean) ;

end Segments.Sgml.Html;

package body Segments.Sgml.Html is

function To Tag (Object : in Sgml Gis.Generic Identifier)
return Tag is

Tag Image : String := Sgml Gis.Get Image (Object);
begin
if Tag Image = "HTML" then
return Html;
elsif Tag Image = "HEAD" then
return Header Side;
elsif Tag Image = "TITLE" then

return Title;



elsif Tag Image = "BASE" then
return Base Url;
elsif Tag Image = "BODY" then
return Body_ Side;
elsif Tag Image = "H1" or Tag Image = "H2" or
Tag_Image = "H3" or Tag Image = "H4" then
return Heading;
elsif Tag Image = "DIV" or Tag_Image = "CENTER" or
Tag_Image = "BLOCKQUOTE" or Tag Image = "FORM" or
Tag_Image = "ADDRESS" then
return High Division;
elsif Tag Image = "P" or Tag Image = "PRE" or
Tag Image = "H5" or Tag Image = "H6" then
return Low_Division;
elsif Tag Image = "HR" then
return Dividing;
elsif Tag Image = "BR" then
return Caesura;
elsif Tag Image = "UL" or Tag Image = "OL" or Tag Image = "DL" or
Tag_Image = "DIR" or Tag Image = "MENU" then
return List;
elsif Tag Image = "LI" then
return Item;
elsif Tag Image = "DT" then
return Definiendum;
elsif Tag Image = "DD" then
return Definiens;
elsif Tag Image = "TABLE" then
return Table;
elsif Tag Image = "CAPTION" then
return Caption;
elsif Tag Image = "ROW" then
return Row;
elsif Tag Image = "TH" then
return Header Cell;
elsif Tag Image = "TD" then
return Data_Cell;
elsif Tag Image = "APPLET" or Tag_Image = "IMG" then
return Alt Media;
elsif Tag Image = "SCRIPT" or Tag_Image = "STYLE" then

return Code;
elsif Sgml Gis.Is_Null (Object) then
return Null Tag;
else
return Other;
end if;
end To Tag;

subtype Level Value is Positive range 1..5;
-- 1, 2 : external tags ;
-- 3 : cf. %body - structured parts
-- 4 : cf. %text - zones included in #PCDATA
-- 5 : nothing - "content" of empty tags

type Column is (Tag Level, Max Level Included) ;
Level Table : array (Tag, Column) of Level Value :=

(Html => Tag Level => 1, Max Level Included =>
Header_Side => Tag Level => 2, Max Level Included => ,
Title => Tag _Level => 3, Max Level Included =>

Base Url =>

Body Side =»>
Heading =>

High Division =>
Low Division =>
Dividing =>

Tag Level =>
Tag_ Level =>
Tag Level =>
Tag_Level =>
Tag Level =>
Tag Level =>
Caesura => Tag_Level =>
List => Tag Level =>

(
(
(
( Max Level Included =>
(

(

(

(

(

(

(

Item => (Tag_Level =>

(

(

(

(

(

(

(

(

(

(

(

Max Level Included =>
Max_Level Included =>
Max Level Included =>
Max_Level Included =>
Max Level Included =>
Max_Level Included =>
Max Level Included =>
Max_Level Included =>
Max Level Included =>
Max_Level Included =>

Definiendum =»> Tag_ Level =>
Definiens => Tag_Level =>

Table => Tag _Level => 3, Max Level Included =>
Caption => Tag Level => 3, Max Level Included => p
Row => Tag _Level => 3, Max Level Included =>

Header_ Cell =>
Data_Cell =>
Alt Media =>
Code =>

Other =>

Null Tag =>

Tag Level =>
Tag Level =>
Tag Level =>
Tag Level =>
Tag Level =>
Tag Level =>

Max_Level Included =>
Max Level Included =>
Max_Level Included =>
Max Level Included =>
Max_Level Included =>
Max Level Included =>
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function Is Transparent (Object : in Tag) return Boolean is
begin

return Object = Other;

end Is_Transparent;

function Is_Base Level (Object : in Tag) return Boolean is
begin
return Level Table (Object, Tag Level) = 3 and
Level Table (Object, Max Level Included) = 4;

end Is_Base Level;

function Is_Infra Level (Object : in Tag) return Boolean is
begin

return Level Table (Object, Tag Level) > 3;

end Is Infra Level;
type Side is (Header Side, Body Side, Unknown) ;

function Get Side (Object : in Tag) return Side is
begin

case Object is
when Html | Other | Null Tag =>
return Unknown;
when Header Side | Title | Base Url | Code =>
return Header Side;
when Body Side | Heading |
High Division | Low Division | Dividing | Caesura
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List | Item | Definiendum | Definiens |

Table | Caption | Row |
Alt_Media =>
return Body_ Side;
end case; -- Object
end Get_Side;

function Can_Contain (Outside, Inside

function No Direct Recursion (Outs

i

ide,

Header Cell | Data Cell |

n Tag) return Boolean is

Inside in Tag)

return Boolean is

function Is_Cell
begin

return Object =
end Is_Cell;

(Object

begin
return (Outside = Inside and
(Inside = Item or Insid
(Is_Cell (Outside) and
(Is_Cell (Inside) or Inside
end No Direct Recursion;

function Are_Side_ Coherent (Outsid

in Tag)

Data_Cell or Object =

e =

= RO

e, I

return Boolean is

Header Cell;

Definiens or Inside = Row))

w) ) ;

nside in Tag)

return Boolean is
(Outside) ;

Outside_Side
Inside_Side
begin
return Outside_Side =
Outside Side = Unknown or
Inside_Side = Unknown;
end Are Side Coherent;

Side :=
Side :=

Get_Side
Get_Side

begin
return (Level Table
<= Level_ Table
Are_Side_ Coherent (Outside,

end Can_Contain;

procedure Find Implicit Tag (From
Next
Towards
Base
No_ More
Next_ Level Level Value;
function Get Default Tag (Level
Of Side
begin
case Level is

(Ins

in

in
in

in
in

ide) ;

Inside_Side or

(Outside, Max Level Included)
(Inside, Tag Level))
Inside)
not No_Direct Recursion (Outside => Outside,

and
and
Inside => Inside);

Tag;
out Tag;
Tag;
Tag;
out Boolean) is

Level Value;
Side) return Tag is

or
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when 1 =>
return Html;
when 2 =>
case Of Side is
when Header Side =>
return Header Side;
when Body Side | Unknown =>
return Body_ Side;
end case; -- Of Side
when 3 =>
return Base;
when 4 | 5 => -- dummy values,
return Null Tag;
end case; -- Level
end Get_Default Tag;

never asked for

procedure Conclude is

begin
Next := Towards;
No More := True;

end Conclude;

begin
case Towards is
when Null Tag =>
Conclude;
when others => --

it cannot be Html (because Can Contain would be

-- false), nor Other (because it is transparent
-- and then not considered) Get_Side (Towards)
-- is always significant

Next Level := Level Table (From, Tag Level) +1;

case Level Table
when True =>

(Towards, Tag Level) > Next Level is

Next := Get_ Default Tag (Level => Next Level,
Of Side => Get Side (Towards));
No More := False;
when False =>
Conclude;
end case; -- Level Table (Towards, Tag Level) > Next Level
end case; -- Towards

end Find Implicit Tag;

procedure Find Implicit Tag (Next out Tag;
Towards in Tag;
Base in Tag;
No_More out Boolean) is
begin
Next := Root_ Tag;
No More := (Towards = Root Tag) ;

end Find Implicit_ Tag;

end Segments.Sgml.Html;



Modules qui en découlent

Balises

with Segments.Sgml.Meta G;

package Segments.Sgml.Html.Meta is new Segments.Sgml.Meta G
(Tag_Category => Tag) ;

Balises ouvrantes

with Segments.Sgml.Html.Meta;
with Segments.Sgml.Meta G.Stag G;

package Segments.Sgml.Html.Stag is new Segments.Sgml.Html.Meta.Stag G;

Balises fermantes

with Segments.Sgml.Html.Meta;
with Segments.Sgml.Meta G.Etag G;

package Segments.Sgml.Html.Etag is new Segments.Sgml.Html.Meta.Etag G;
Balises indéfinies

with Segments.Sgml.Html.Etag;
with Segments.Sgml.Html.Meta;
with Segments.Sgml.Html.Stag;
with Segments.Sgml.Mixed G;

package Segments.Sgml.Html.Mixed is
new Segments.Sgml.Mixed G (Meta => Segments.Sgml.Html.Meta,
Stag => Segments.Sgml.Html.Stag,
Etag => Segments.Sgml.Html.Etag) ;

Contexte structurel

with Segments.Sgml.Html.Etag;
with Segments.Sgml.Html.Meta;
with Segments.Sgml.Html.Stag;
with Segments.Sgml.Contexts G;

use Segments.Sgml.Html;

package Segments.Sgml.Html.Contexts is new Segments.Sgml.Contexts G
(Meta => Segments.Sgml.Html.Meta,
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Stag => Segments.Sgml.Html.Stag,
Etag => Segments.Sgml.Html.Etag,
Default Base => Segments.Sgml.Html.Default Base);
e) Uneautreinstance de segments SGML : les
segments Corpus

Définition du jeu de balises et de son comportement
with Sgml Gis;
package Segments.Sgml.Decid is

type Tag is (Corpus, Doc, Ref, Arr, Box, Text, Tit, Head, Nls,
Idea, Expr, Blck, Scop, Item, Meta, Null Tag);

function To_Tag (Object : in Sgml Gis.Generic_Identifier)
return Tag;

Root_Tag : constant Tag := Corpus;
Default Base : constant Tag := Nls;
function Is_ Transparent (Object : in Tag) return Boolean;

-- Transparent means that Object should not be recorded in Tag Context

function Is Base Level (Object : in Tag) return Boolean;
-- used for setting Base in Tag Context

function Is_Infra Level (Object : in Tag) return Boolean;
function Can_Contain (Outside, Inside : in Tag) return Boolean;
procedure Find Implicit Tag (From : in Tag;

Next : out Tag;

Towards : in Tag;

Base : in Tag;

No_ More : out Boolean) ;

-- using Find Implicit Tag supposes that Can Contain (From, Towards)

procedure Find Implicit Tag (Next : out Tag;
Towards : in Tag;
Base : in Tag;
No_ More : out Boolean) ;

end Segments.Sgml.Decid;
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return False;
with Logs; end Is_ Transparent;
package body Segments.Sgml.Decid is function Is_Base Level (Object : in Tag) return Boolean is
begin
function To Tag (Object : in Sgml Gis.Generic Identifier) return ((Level Table (Object, Tag Level) = 3 and
return Tag is Level Table (Object, Max Level Included) > 3) or
begin ((Object = Ref) or (Object = Arr) or (Object = Box)));
case Sgml Gis.Is_Null (Object) 1is end Is_Base_Level;
when True =>
return Null Tag; function Is Infra Level (Object : in Tag) return Boolean is
when False => begin
return Tag’Value (Sgml_Gis.Get Image (Object)); return Level Table (Object, Tag Level) > 3;
end case; -- Sgml Gis.Is_Null (Object) end Is_Infra Level;
exception
when Constraint Error => function Can_Contain (Outside, Inside : in Tag) return Boolean is
Logs.Write (Kind => Logs.Error,
Localization => "Segments.Sgml.Decid.To Tag", function No Direct Recursion (Outside, Inside : in Tag)
Exception Name => "Constraint Error", return Boolean is
Propagated => True) ; begin
Logs.Write (Message => Sgml Gis.Get Image (Object) & return (Outside = Inside and
" is not a Decid Tag.", (Inside = Item or Inside = Meta or Inside = Idea));
Ends_The Line => True); end No_Direct_ Recursion;
raise;
end To_Tag; begin
return (Level Table (Outside, Max Level Included)
subtype Level Value is Natural range 0..5; <= Level Table (Inside, Tag Level)) and
-- 0 packaging tag ; not No_Direct Recursion (Outside => Outside, Inside => Inside);
-- 1, 2 : external tags ; end Can_ Contain;
-- 3 : text structuration
-- 4 textual zones, inside parts procedure Find Implicit Tag (From : in Tag;
-- 5 pure text Next : out Tag;
type Column is (Tag Level, Max Level Included) ; Towards : in Tag;
Level Table : array (Tag, Column) of Level Value := Base : in Tag;
(Corpus => (Tag_Level => 0, Max Level Included => 1), No_More : out Boolean) is
Doc => (Tag_Level => 1, Max Level Included => 2), Next_ Level : Level_Value;
Ref => (Tag Level => 2, Max Level Included => 5),
Arr => (Tag Level => 2, Max Level Included => 5), function Get_Default_Tag (Level : in Level Value) return Tag is
Box => (Tag Level => 2, Max Level Included => 5), begin
Text => (Tag_Level => 2, Max Level Included => 3), case Level is
Tit => (Tag Level => 3, Max Level Included => 4), when 0 =>
Head => (Tag_Level => 3, Max Level Included => 4), return Corpus;
Nls => (Tag Level => 3, Max Level Included => 4), when 1 =>
Idea => (Tag_Level => 4, Max Level Included => 4), return Doc;
Expr => (Tag Level => 4, Max Level Included => 5), when 2 =>
Blck => (Tag_Level => 3, Max Level Included => 3), return Text;
Scop => (Tag Level => 3, Max Level Included => 3), when 3 =>
Item => (Tag_Level => 3, Max Level Included => 3), return Base;
Meta => (Tag Level => 3, Max Level Included => 3), when 4 | 5 => -- dummy values, never asked for
Null Tag => (Tag Level => 4, Max Level Included => 5)); return Null Tag;
end case; -- Level
function Is_Transparent (Object : in Tag) return Boolean is end Get_Default_Tag;
begin



procedure Conclude is

begin
Next := Towards;
No More := True;

end Conclude;

begin
case Towards = Null Tag is
when True =>
Conclude;
when False =>

Next Level := Level Table (From, Tag Level) +1;
case Level Table (Towards, Tag Level) > Next Level is

when True =>

Next := Get_Default Tag (Next Level);
No_More := False;
when False =>
Conclude;
end case; -- Level Table (Towards, Tag Level) > Next Level
end case; -- Towards = Null Tag

end Find Implicit Tag;

procedure Find Implicit Tag (Next

Towards
Base
No_ More
begin
Next := Root_Tag;
No More := (Towards = Root_Tag) ;

end Find Implicit_Tag;

end Segments.Sgml.Decid;

M odules qui en découlent

Balises

with Segments.Sgml.Meta G;

out Tag;
in Tag;
in Tag;

out Boolean) is

package Segments.Sgml.Decid.Meta Pkg is new Segments.Sgml.Meta G

(Tag_Category => Tag) ;

Balises ouvrantes

with Segments.Sgml.Decid.Meta_Pkg;
with Segments.Sgml.Meta G.Stag G;

package Segments.Sgml.Decid.Stag is new

Segments.Sgml.Decid.Meta Pkg.Stag G;
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Balises fermantes

with Segments.Sgml.Decid.Meta_ Pkg;
with Segments.Sgml.Meta G.Etag G;

package Segments.Sgml.Decid.Etag is new
Segments.Sgml.Decid.Meta_ Pkg.Etag G;

Balises indéfinies

with Segments.Sgml.Decid.Etag;
with Segments.Sgml.Decid.Meta_ Pkg;
with Segments.Sgml.Decid.Stag;
with Segments.Sgml.Mixed G;

package Segments.Sgml.Decid.Mixed is
new Segments.Sgml.Mixed G (Meta => Segments.Sgml.Decid.Meta_ Pkg,
Stag => Segments.Sgml.Decid.Stag,
Etag => Segments.Sgml.Decid.Etag) ;

Contexte structurel

with Segments.Sgml.Decid.Etag;
with Segments.Sgml.Decid.Meta Pkg;
with Segments.Sgml.Decid.Stag;
with Segments.Sgml.Contexts G;

use Segments.Sgml.Decid;

package Segments.Sgml.Decid.Contexts is new Segments.Sgml.Contexts G

(Meta => Segments.Sgml.Decid.Meta Pkg,
Stag => Segments.Sgml.Decid.Stag,
Etag => Segments.Sgml.Decid.Etag,

Default Base => Segments.Sgml.Decid.Default Base) ;
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4. Utilitaires

a) Tailles: la gestion des ordres de grandeur

package Sizes is

type Size is (S, M, L, XL);

--| Read Formatted Files

--| Each line is a set of field. Fields are separated by '
--| user defined separators.

--| The file name "-" is used for standard input.
generic
Max Field Positive := 30;

Max_Line Length Positive 1_000;

package Read File is

XS Value : constant Positive := 8;

S Value : constant Positive := 64;

M Value : constant Positive := 250;
L_Value : constant Positive := 4_000;
XL _Value : constant Positive := 64_000;

subtype S Positive is Positive range 1..S Value;
subtype M Positive is Positive range 1..M Value;
subtype L_Positive is Positive range 1..L Value;
subtype XL Positive is Positive range 1..XL Value;

subtype S Natural is Natural range 0..S Value;
subtype M Natural is Natural range 0..M Value;
subtype L Natural is Natural range 0..L_Value;
subtype XL Natural is Natural range 0..XL Value;

function To Number (Notation : in Size) return Positive;

end Sizes;

b) Lecturedefichierstabulés

Component
$Id: read file.ads,v 1.1.1.1 1998/04/17 12:20:12 obry Exp $

Author : Pascal Obry
e-mail : 101465.2502@compuserve.com

Machine/System Compiled/Run on : SPARC SUN-0S, Windows NT - GNAT

subtype Field Range is Positive range 1 Max Field;
procedure Open (Name
procedure Close;
procedure Set Separators (To : in String);
--| define a set of separators

in String);

procedure Fetch;

--| read next line

function End Of File
return Boolean;

function Is Empty Line
return Boolean;

function Number Of Fields
return Natural;
--| number of field for the current line

function Line Number
return Natural;

--|] to get the separator that has been used to cut the field.

function Separator For Field (N : in Field Range)
return Character;

--|] to get the value of a field as a String, Integer, Float
function Field (N : in Field Range)
return String;
function Field (N : in Field Range)
return Integer;
function Field (N : in Field Range)
return Float;

--] to get the value of a field as a user defined type.
generic

ANNEXE V.3
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type T is (<>);

function Field Of Type (N : in Field Range) generic
return T; type Arg 1 Type is limited private;
with function Arg 1 Default Value return Arg 1 Type;
end Read File; with procedure Action (Object : in Object Root;
Arg 1 : in Arg 1 Type :=
L. . . Arg 1 Default Value);
C) Un gene”que pour COﬂStI‘UII‘eet mar“puler deS procedure Dispatching Procedure G (Object : in Polymorphic Object;
. Arg 1 : in Arg 1 Type :=
objets polymorphes Arg 1 Default Value) ;

generic

with Ada.Finalization; type Arg 1 Type is limited private;

with function Arg 1 Default Value return Arg 1 Type;
with procedure Action (Object : in out Object Root;
Arg 1 : in Arg 1 Type :=
Arg 1 Default Value);
i . i procedure Dispatching Modifying Procedure G
package Polymorphic Objects G is (Object : in out Polymorphic Object;
Arg 1 : in Arg 1 Type := Arg 1 Default Value);

generic

type Object Root is abstract tagged private;

type Polymorphic Object is private;
generic
type Result Type is limited private;
with function Action (Object : in Object Root)
return Result Type;
function Dispatching Function G (Object : in Polymorphic Object)
return Result Type;

Type Error : exception;

function Is_Undefined (Object : in Polymorphic Object)
return Boolean;

procedure Reset (Object : in out Polymorphic Object) ; -- Specific subprogramms --

; generic
-- Conversions -- type Object Child is new Object Root with private;
. type Result Type is limited private;
generic ) . . ) ) ) with function Action (Object : in Object Child)
type Object Child is new Object Root with private; return Result Type7
function To_Polymorphic G (Object : in Object Child) function Child Function G (Object in Polymorphic Object)
return Polymorphic Object; return Result Type; -

generic generic

type Object_Child is new Object Root with private;
function To Child G (Object : in Polymorphic Object)
return Object Child;

type Object Child is new Object Root with private;
type Value Type is limited private;
with procedure Action (Object : in out Object Child;
Value : in Value_ Type) ;
procedure Child Procedure G (Object : in out Polymorphic Object;
Value : in Value_ Type) ;

-- Dispatching subprogramms --

type Object Access is access all Object Root’Class;

function Get Details (Object : in Polymorphic Object)

- private
return Object Access;

type Polymorphic_Object is new Ada.Finalization.Controlled with

-- The following generics can only be used with a non abstract Action record
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Details
end record;

Object Access;

procedure Adjust (Object
procedure Finalize (Object

in out Polymorphic_Object) ;
in out Polymorphic Object) ;

end Polymorphic Objects G;

with Ada.Unchecked Deallocation;
with Logs;

package body Polymorphic Objects G is

function Get Details (Object in Polymorphic Object)
return Object Access is
begin
return Object.Details;
end Get_Details;

function Is Undefined (Object in Polymorphic Object)
return Boolean is
begin
return Get Details (Object) = null;
end Is Undefined;

procedure Reset (Object
begin
Object := Polymorphic Object’
(Ada.Finalization.Controlled with
Details => null);

in out Polymorphic Object) 1is

end Reset;

-- Conversions --

-- generic
-- type Object_Child is new Object Root with private;
function To Polymorphic G (Object in Object Child)
return Polymorphic_Object is
begin
return Polymorphic_Object’ (Ada.Finalization.Controlled with
Details => new Object Root’Class’ (Object Root’Class
(Object))) ;
end To Polymorphic G;

-- generic
-- type Object_Child is new Object Root with private;
function To Child G (Object in Polymorphic Object)
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return Object Child is
begin
return Object Child (Object.Details.all);
exception
when Constraint Error =>
pragma Debug (Logs.Write (Kind => Logs.Trace,
Localization => "instance of " &
"Polymorphic_Objects_G.To_ Child G",
Exception Name =>
"Constraint_ Error",
Propagated => True,
Propagation Name =>
"Polymorphic Objects G.Type Error"));
raise Type Error;
end To_Child Gj;

-- Dispatching subprogramms --

-- generic

-- type Arg 1 Type is limited private;

-- with function Arg 1 Default Value return Arg 1 Type;

-- with procedure Action (Object in Object Root;

-- Arg 1 in Arg_ 1 Type :=

-- Arg_1 Default Value) is <>;
procedure Dispatching Procedure G (Object in Polymorphic Object;

Arg 1 in Arg 1 Type =
Arg 1 Default Value) is
begin
Action (Object => Object Root (Object.Details.all),

Arg 1 => Arg 1);
end Dispatching Procedure G;

-- generic
-- type Arg 1 Type is limited private;
-- with function Arg 1 Default Value return Arg 1 Type;
-- with procedure Action (Object in out Object Root;
-- Arg 1 in Arg_ 1 Type :=
-- Arg_1 Default Value) is <>;
procedure Dispatching Modifying Procedure G
(Object in out Polymorphic Object;
Arg 1 in Arg_ 1 Type :=
Arg 1 Default Value) is
begin
Action (Object => Object Root (Object.Details.all), Arg 1 => Arg 1);
end Dispatching Modifying Procedure G;

-- generic
-- type Result Type is limited private;
-- with function Action (Object in Object_Root)
-- return Result Type is <>;
function Dispatching Function G (Object in Polymorphic Object)
return Result Type is



begin end Finalize;
return Action (Object => Object Root (Object.Details.all));
end Dispatching Function G; -

———————————————————————————————————————————————————————————————————————— end Polymorphic_Objects_G;
-- Specific subprogramms --

-~ generic 5. Donnéesauxiliaires

-- type Object Child is new Object Root with private;
-- type Result Type is limited private;
-- with function Action (Object : in Object Child) Lz
-- return Result Type is <>; a) EntlteS SGML
function Child Function G (Object : in Polymorphic Object)
return Result Type is
function To_Child is new
To_Child G (Object_Child => Object_Child) ;
begin
return Action (Object => To_Child (Object)) ;
end Child Function G;

aacute=4=LAT1=225=
Aacute=A=LAT1=193=
acirc=4=LAT1=226=
Acirc=A=LAT1=194=

Agrave=A=LAT1=192=

aring=4=LAT1=229=

Aring=A=LAT1=197=

atilde=8=LAT1=227=

Atilde=A=LAT1=195=

auml=4=LAT1=228=

Auml=A=LAT1=196=

aelig=2=LAT1=230=

AElig=E=LAT1=198=

ccedil=¢=LAT1=231=

[...]

agr=a=GRK1=97=alpha

Agr=A=GRK1=65=Alpha

bgr=b=GRK1=98=Dbeta

[...]

aleph==TECH=0=aleph

and==TECH=0=1logical and
ap==TECH=0=approximate
bottom==TECH=0=perpendicular

[...]

half=1/2=NUM=189=fraction one-half
fracl2=1/2=NUM=189=fraction one-half
fracl4=1/4=NUM=188=fraction one-quarter
frac34=3/4=NUM=190=fraction three-quarters
fracl8=1/8=NUM=49=47=56=fraction one-eighth
frac38=3/8=NUM=51=47=56=fraction three-eighths
[...]

-- generic
-- type Object_Child is new Object Root with private;
-- type Value Type is limited private;
-- with procedure Action (Object : in out Object_ Child;
-- Value : in Value Type) is <>;
procedure Child Procedure G (Object : in out Polymorphic_Object;
Value : in Value Type) is
Work Object : Object Child;
function To Polymorphic is
new To_Polymorphic G (Object Child => Object_ Child) ;
function To_Child is new
To_Child G (Object Child => Object_Child) ;
begin
Work Object := To Child (Object) ;
Action (Object => Work Object,
Value => Value) ;
Object := To Polymorphic (Work Object) ;
end Child Procedure G;

procedure Adjust (Object : in out Polymorphic Object) is
begin

Object.Details :=

new Object Root’Class’ (Object.Details.all);
end Adjust;

procedure Finalize (Object : in out Polymorphic_Object) is
procedure Free is
new Ada.Unchecked Deallocation (Object => Object Root’Class,
Name => Object Access);
begin
Free (Object.Details);
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